Mailinglist Archive: opensuse (3288 mails)

< Previous Next >
Re: [opensuse] Problem with Yast2 - error when loading config modules
  • From: Anders Johansson <ajh@xxxxxxxxxx>
  • Date: Sun, 23 Dec 2007 14:18:54 +0100
  • Message-id: <200712231418.55160.ajh@xxxxxxxxxx>
On Sunday 23 December 2007 14:09:08 Rodney Baker wrote:
Hi all. I have a problem with Yast 2 generating an error message when
trying to load certain modules, such as the User Management module under
Security and Users. It started after attempting to change the Mail Transfer
Agent settings.

The message complained about not being able to find Net/IMAP.pm in the Perl
@INC path. I fixed it through cpan with a 'force install Net::IMAP' which
shut up the message and allowed me to get back into the user admin
interface, but I shouldn't have had to do this.

No you shouldn't. These perl packages are all available as rpms in suse. And
forced installations should never ever be done unless you're *very* sure of
what you're doing. It is an excellent way of breaking a system

Any ideas on what could cause this in the first place anyone?

For some reason the rpm was uninstalled. I can't tell why without looking at
your log files

Anders
--
Madness takes its toll
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups
References