Mailinglist Archive: opensuse (4244 mails)

< Previous Next >
Re: [opensuse] ieee80211 Subsystem - compile ipw3945
  • From: Carl Luescher <wc.luescher@xxxxxxxxxxxxx>
  • Date: Sun, 14 Oct 2007 22:25:39 -0400
  • Message-id: <200710142225.39301.wc.luescher@xxxxxxxxxxxxx>
On Sunday 14 October 2007 08:58, Ben Kevan wrote:
> I am trying to compile ipw3945 from source, and when I try.. I get the
> following:
>
>
> ---------------------------------------------------------------------------
>----------------------------------------------------------- ipw3945-1.2.2>
> make IEEE80211_IGNORE_DUPLICATE=y
>
>  WARNING: Your kernel contains ieee80211 symbol definitions and you
> are not using the kernel's default ieee80211 subsystem.  (Perhaps you
> used the out-of-tree ieee80211 subsystem's 'make install' or have
> provided a path to the ieee80211 subsystem via IEEE80211_INC.)
>
> If you wish to use the out-of-tree ieee80211 subsystem then it is
> recommended to use that projects' "make patch_kernel" facility
> and rebuild your kernel to update the Module symbol version information.
>
> Failure to do this may result in build warnings and unexpected
> behavior when running modules which rely on the ieee80211 subsystem.
>
>  ERROR: A compatible subsystem was not found in the following path[s]:
>
>         /lib/modules/2.6.23-gbbf25010-13-default
> /lib/modules/2.6.23-gbbf25010-13-default/build
>
> You need to install the ieee80211 subsystem from http://ieee80211.sf.net
> and point this build to the location where you installed those sources,
> eg.:
>
>         % make IEEE80211_INC=/usr/src/ieee80211/
>
> or use the 'make patch_kernel' within the ieee80211 subsystem to patch your
> kernel sources.
>
> make: *** [check_inc] Error 1
> ---------------------------------------------------------------------------
>-----------------------------------------------------------
>
>
> My question is, where is the subsystem located?
>
> I know of the following:
>
> /lib/modules/2.6.23-gbbf25010-13-default/kernel/net/ieee80211
> /lib/modules/2.6.23-gbbf25010-13-default/kernel/net/ieee80211/ieee80211.ko
> /lib/modules/2.6.23-gbbf25010-13-default/kernel/net/ieee80211/ieee80211_cry
>pt.ko
> /lib/modules/2.6.23-gbbf25010-13-default/kernel/net/ieee80211/ieee80211_cry
>pt_ccmp.ko
> /lib/modules/2.6.23-gbbf25010-13-default/kernel/net/ieee80211/ieee80211_cry
>pt_tkip.ko
> /lib/modules/2.6.23-gbbf25010-13-default/kernel/net/ieee80211/ieee80211_cry
>pt_wep.ko
>
> but when I try to compile with:
>
> make IEEE80211_IGNORE_DUPLICATE=y
> IEEE80211_INC=/lib/modules/2.6.23-gbbf25010-13-default/source/net/ieee80211
>/
>
> It's still a no-go.
>
> So.. how can I get around this?
>
> Ben
I just did this today.  I had to download the kernel source files, run make 
cloneconfig in the /usr/src/linux directory.  Not sure if required but I was 
customizing my kernel anyway so I ran the make bzImage, make modules then 
make modules_install and manually configured the kernel to boot.  After 
rebooting to the new kernel I went and ran make from the ipw3945-1.2.0 
directory with no problems.  I tried ipw3945-1.2.2 but for some reason 
refuses to connect.  Hope this helps.

Carl
-- 
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >
References