Mailinglist Archive: opensuse (4253 mails)

< Previous Next >
Re: [opensuse] OpenOffice freezes the system
  • From: Brad Bourn <brad@xxxxxxxxxxxx>
  • Date: Wed, 3 Oct 2007 10:19:06 -0600
  • Message-id: <200710031019.06763.brad@xxxxxxxxxxxx>
I have been seeing this problem for a long time.

For me, it is only ever triggered when I "click" on a menu item.  Mostly 
the "File" menu item.  However, as I read this comment, I froze it up on 
the "Tools" menu, as suggested.

I have nVidia driver (commercial), using "Twinview" with an amd_64 running the 
generic version of OOo (not a specific SuSE version).

This has been happening with upgrades of SuSE, OOo, and nVidia.  Nothing seems 
to handle it.  

From watching this thread, I'm suspect of non-SuSE versions.

The system doesn't actually freeze though.  You (I) can connect via ssh, and 
see that what is happened is that the Xorg thread is using all CPU making 
keyboard, etc. un-responsive.  ssh session seems to be full speed though.  
All I ever have to do is kill -s 09 Xorg (from another PC, ssh'ed into frozen 
machine) and system comes back.

Interesting part is that when I re-open the OOo calc sheet, the recovery 
wizard comes up, and shows documents that I ~had~ closed that it must have 
thought was still open.

I'm going to try and only access the menu items with keyboard shortcuts, 
instead of mouse clicks.  I'm suspect that it is the original "click" on the 
menu item  (not even enough time for 'release' of mouse) that is causing Xorg 
to loop, blocking other processes.


B-)

On Wednesday 03 October 2007 3:38 am, Carlos E. R. wrote:
> 
> The Wednesday 2007-10-03 at 09:13 +0100, Kevin Donnelly wrote:
> 
> > OOo froze pretty consistently here, on 10.2 with the NVidia 100.14.11 
drivers.
> > It did that with the original install version (2.0.4), and also with the
> > 2.3.0 version - it happened only an hour ago this morning (foolish me - I
> > thought I'd try it again, just to see), and required a hard reboot.
> 
> OOo has some 3D effects: try dissabling them. I guess they use some vdeo
> card gadgetry. Otherwise, try using the open driver instead of the closed
> source one.
> 
> Look at OOo / Tools /  3D view: use open GL, dithering, refresh, and
> specially "hardware acceleration".
> 
> --
> Cheers,
>         Carlos E. R.
> 
> 
> -- 
> To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
> For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx
> 
> 
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >