Mailinglist Archive: opensuse (1956 mails)

< Previous Next >
Re: [opensuse] Which version of Openoffice to install on 10.2?
  • From: "Joe Morris (NTM)" <Joe_Morris@xxxxxxx>
  • Date: Thu, 09 Aug 2007 08:43:11 +0800
  • Message-id: <46BA631F.4010604@xxxxxxx>
On 08/08/2007 10:01 PM, Clayton wrote:
>> Since he used the rpm version, no need to uninstall first (i.e rpm -V
>> OpenOffice_org will verify the rpm files).  He could also add the build
>> repository for OpenOffice Stable to get a newer version via Yast.  HTH.
>>     
>
> Right, but since this was all done in YAST... I don't use YAST much at
> all to do my software management... on 10.2 I do it all via Smart an
> the various repositories, or command line.. and even then I tend to
> use "smart install some.rpm" so that the dependencies are (usually)
> resolved on the fly
>   
I used smart with 10.1, because zen rendered Yast useless for software
management practically (too many repositories + zen = cpu stress, few
repositories + zen = possible for update but nothing else).  With 10.2
with opensuseupdater, I can have my repositories needed for software
management and use it everyday too, so I only use Yast again (like 9.3)
[ok, some things I use CLI and a few Kpackage, all local files].
> Some questions so I understand and learn something here... Is it
> easy/possible to verify the RPM files from within YAST? 
Verify, not that I am aware of.  Easiest for that is KPackage.  It is
GUI and will verify graphically with a green check or red X for a bad file.
>  What are you
> verifying them against? 
rpm database I assume.
>  How will this help with the possible problem
> of multiple versions installed as the original poster indicated (this
> would mean a broken RPM database? or something else?)?
>   
If he only used Yast, he does NOT have multiple versions INSTALLED.  I
think he said there were multiple versions LISTED under the versions tab
in Yast, each corresponding to the various repositories configured, in
usually i586 and x86_64 arch for a 64 bit system.  In 10.2 the default
is an i586 OO install.  If he added the OO build repository, he would
have even more listed, and could upgrade to the latest Novell version
available.  That would be better than a reinstall of the older version. 
Chances are best any problem he has are in his local config anyway, not
the files being reinstalled.  If it was a bug, it may be fixed in the
latest version.  HTH.

-- 
Joe Morris
Registered Linux user 231871 running openSUSE 10.2 x86_64





-- 
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >