Mailinglist Archive: opensuse (1632 mails)

< Previous Next >
Re: [opensuse] yast online update
  • From: Dave Howorth <dhoworth@xxxxxxxxxxxxxxxxx>
  • Date: Thu, 19 Jul 2007 10:00:01 +0100
  • Message-id: <469F2811.9010504@xxxxxxxxxxxxxxxxx>
Marcus Meissner wrote:

<snip reply that I'll need to check on my 10.2 system this evening>

>>>> The final aspect is specific to gtk2. There is a patch for gtk2, which I
>>>> have installed. Why can't I see a matching patch to gtk2-debuginfo?
>>>> There's a version conflict. Am I misunderstanding something or is this a
>>>> bug?
>>> We do not ship updates for -debuginfo packages, you need to deinstall 
>>> gtk2-debuginfo before updating.
>> Have I understood you correctly: As soon as there's an update to a
>> package, it's no longer possible to debug it?
> 
> You can still debug it and the debugger will show a backtrace at least,
> its just that the debuginfo package cannot be used.
> (The reason we leave them out is just bandwith and diskspace issues.)

  "given enough eyeballs, all bugs are shallow"

Helping to find bugs is one of the very few things I feel able to
contribute back to the community. This policy means I can't help in such
situations.

There's a problem in gtk that apparently only shows up in some
configurations. I happen to have a configuration where it shows up and
was asked to try debugging with symbols to help locate it.

I know I could in theory recompile everything myself but I'm not
confident I know how to get exactly the same configuration and they
couldn't be sure either, so lack of the debuginfo package is a high
enough barrier in this case to reduce the number of eyeballs.

If there's any possibility to change this policy, I believe it would be
helpful to the goals of increasing quality and reducing costs.

Cheers, Dave
-- 
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >