Mailinglist Archive: opensuse (2372 mails)

< Previous Next >
Re: [opensuse] Spyware on my laptop? (hope it's not OT)
  • From: "Ciro Iriarte" <cyruspy@xxxxxxxxx>
  • Date: Sat, 9 Jun 2007 17:07:16 -0400
  • Message-id: <a998a0140706091407r3e2ff935t9696498d8dcc4160@xxxxxxxxxxxxxx>
2007/6/9, John Andersen <jsa@xxxxxxxxxxxxxx>:
On Saturday 09 June 2007, Ciro Iriarte wrote:
> I'm kind of lost, the DNS are ok here (internal) and at home (provided
> by the ISP), double checked that.... Already tried konqueror. Tried
> the tcptraceroute/traceroute comparison as suggested, and there's no
> variation in the hops, so i think that implies there's no proxy...

Ok, so no proxy.

What about those contemptible DNS re-director "Services" that some
ISPs are starting to provide where they direct you to some internally
generated search engine (complete with adware) for anything that
comes back as not found?

This would likely be at your ISP.

This type of software was originally intended for Hotels and hotspots, but
I've seen it show up in other places, where the ISPs add this layer
to gain a little revenue on the cheap, and not just on wireless
networks.  Some use it to redirect

www.dnsredirector.com is one such software.
http://downloads.zdnet.com/search.aspx?compid=50500

Even some big ISPs are getting into this nonsense:
http://www.betanews.com/article/EarthLink_Criticized_for_DNS_Redirects/1157575614

How to test:
Research the DNS server IPs for other ISPs, they don't
even have to be physically close to you.

Go into /etc/resolv.conf with a regular text editor and change
the nameserver lines to point to the other dns servers.

Then clear your browser cache and try your inquiry again.

NOTE:  You can very often use a different ISPs dns server if
you suspect your ISPs server is lame, slow, broken, or
something.  Most ISPs do not filter external DNS requests
because the resources needed to to this exceed the resources
needed to serve the request.  Don't abuse this.

--
_____________________________________
John Andersen

Gladly there's no such a thing on my ISP, the problem was caused by a
misconfigured resolv.conf. I was using local.net for my LAN's domain
and it exists. Combined with a catch-all rule for local.net caused
this strange behaviour.

Thanks a lot
Ciro
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >