Mailinglist Archive: opensuse (2831 mails)

< Previous Next >
[SLE] Error 13: Invalid or unsupported executable format
  • From: "Steve Valimaki" <svalimaki@xxxxxxxxx>
  • Date: Sun, 2 Jul 2006 14:41:18 -0400
  • Message-id: <2105de7e0607021141j5ce44d32k16130d74187d7d2a@xxxxxxxxxxxxxx>
Hi, I see the message in the subject field on my dual boot laptop. I can
boot Suse 9.3 just fine (2.6.11.4-21.9-default), but cannot boot Windows XP.
My /boot/grub/menu.lst file:

# Modified by YaST2. Last modification on Sat Jul 1 16:47:30 EDT 2006

color white/blue black/light-gray
default 0
timeout 8
gfxmenu (hd0,2)/message

###Don't change this comment - YaST2 identifier: Original name: windows###
title WinBlows
rootnoverify (hd0,1)
makeactive
chainloader +1

###Don't change this comment - YaST2 identifier: Original name: linux###
title SUSE LINUX 9.3
kernel (hd0,2)/vmlinuz root=/dev/sda5 vga=0x317 selinux=0 splash=silent
resume=/dev/sda6 showopts
initrd (hd0,2)/initrd

###Don't change this comment - YaST2 identifier: Original name: xen###
title XEN
kernel (hd0,2)/xen.gz dom0_mem=2031616
module (hd0,2)/vmlinuz-xen root=/dev/sda5 vga=0x317 selinux=0
splash=silent resume=/dev/sda6 showopts
module (hd0,2)/initrd-xen

###Don't change this comment - YaST2 identifier: Original name: failsafe###
title Failsafe -- SUSE LINUX 9.3
kernel (hd0,2)/vmlinuz root=/dev/sda5 showopts ide=nodma apm=off
acpi=off vga=normal noresume selinux=0 barrier=off nosmp noapic maxcpus=0 3
initrd (hd0,2)/initrd

###Don't change this comment - YaST2 identifier: Original name: memtest86###
title Memory Test
kernel (hd0,2)/memtest.bin

fdisk output:

kira:~ # fdisk -l

Disk /dev/sda: 80.0 GB, 80026361856 bytes
255 heads, 63 sectors/track, 9729 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/sda1 1 261 2096451 de Dell Utility
/dev/sda2 * 262 7655 59392305 7 HPFS/NTFS
/dev/sda3 7656 7668 104422+ 83 Linux
/dev/sda4 7669 9728 16546950 f W95 Ext'd (LBA)
/dev/sda5 7669 8803 9116856 83 Linux
/dev/sda6 8804 8934 1052226 82 Linux swap / Solaris
/dev/sda7 8935 9728 6377773+ c W95 FAT32 (LBA)

This was working, but ran a sgp_dd test and since then, cannot boot Windows.
I can manually mount sda1, but can't mount sda2:
kira:~ # mount -t ntfs -o rw /dev/sda2 /test
mount: wrong fs type, bad option, bad superblock on /dev/sda2,
missing codepage or other error
In some cases useful info is found in syslog - try
dmesg | tail or so

I'd like to at least boot XP one more time to get some files off, and then
I'm fine with reloading Windows.

Any help is appreciated.

Thanks,
Steve
< Previous Next >
This Thread
  • No further messages