Mailinglist Archive: opensuse (3397 mails)

< Previous Next >
Re: [SLE] need libcrypto.so.2 ??
  • From: Jostein Berntsen <jbernts@xxxxxxxxxxxx>
  • Date: Sat, 2 Apr 2005 02:42:49 +0200
  • Message-id: <20050402004249.GC5115@xxxxxxxx>
On 01.04.05,14:23, Tom Peters wrote:
> * newbie warning: extreme inexperience ahead * Please speak slowly and
> clearly * thank you *
>
> Hello all, read the archive back about a years or so, no joy on this
> subject. Trying to install an rpm on SuSE 9.2 called
> cpqarrayd-2.0-1.i386.rpm which is supposed to get messages from my Compaq
> smartarray-2P / SmartArray 3200 SCSI raid controller and log them.
>
> I also have cpqarrayd-2.0-1.src.rpm and cpqarrayd-2.0.tar.gz but haven't
> tried to use them yet.
>
> When I try to install it, it barks at me about a lib:
> rpm -Uvh cpqarrayd-2.0-1.i386.rpm
> error: Failed dependencies:
> libcrypto.so.2 is needed by cpqarrayd-2.0-1
>
> I know little about libs and dependencies. I tries to use yast to get this
> lib-- no joy. I tried to search for it, not found. I added "provides" and
> behold, openssl provides libcrypto, but it's version 0.9.7 and in SuSE its
> in /usr/lib and I suspect that's not where the package is looking for it.
>
> I have no clue how to tell it where to find it. Trying to trick the
> install, I made a sym link to the 0.9.7 called libcrypto.so.2 in /usr/lib
>
> Then I ran ldconfig (because someone else suggested it, not because I
> understand why) and even rehash.
>
> Rerunning rpm results in the same message as before.
>
> What should I try next?
>
>

Have you tried a Suse rpm of the package?

http://tweegy.demon.nl/download/cpqarrayd-SuSe9.0/

- Jostein

--
Jostein Berntsen <jbernts@xxxxxxxxxxxx>

< Previous Next >
Follow Ups
References