Mailinglist Archive: opensuse (3397 mails)

< Previous Next >
Re: [SLE] need libcrypto.so.2 ??
  • From: Anders Johansson <andjoh@xxxxxxxxxx>
  • Date: Tue, 5 Apr 2005 00:47:25 +0200
  • Message-id: <200504050047.25505.andjoh@xxxxxxxxxx>
On Tuesday 05 April 2005 00:34, Tom Peters wrote:
> At 01:36 PM 4/2/2005 +0200, you wrote:
> >Tom Peters <tpeters@xxxxxxxxxx> [Fri, 01 Apr 2005 14:23:16 -0600]:
> > >I also have cpqarrayd-2.0-1.src.rpm and cpqarrayd-2.0.tar.gz but
> > > haven't tried to use them yet.
> > >
> > >When I try to install it, it barks at me about a lib:
> > >rpm -Uvh cpqarrayd-2.0-1.i386.rpm
> > >error: Failed dependencies:
> > > libcrypto.so.2 is needed by cpqarrayd-2.0-1
> >
> >The .rpm has been built for a different distribution. You should rebuild
> >it so that it matches your system. Do so by installing the .src.rpm,
> >change to /usr/src/packages/SRC and call 'rpmbuild -bb cpqarrayd'. After
>
> I had no problems installing the src.rpm, well it's not hard, but I'm not
> sure where to go to build the new rpm-- in /usr/src/packages the only
> directories I have are BUILD RPMS SOURCES SPECS SRPMS

Just use "rpm --rebuild cpqarrayd-2.0-1.src.rpm", it will do everything for
you

>
> Also, when building the source rpm, it groused about this: "warning: user
> spark does not exist, using root." Is this a problem?

No, it just means that whoever created the src.rpm had the user name spark on
his system. It's not important

< Previous Next >
Follow Ups
References