Mailinglist Archive: opensuse (3666 mails)

< Previous Next >
Re: [SLE] stupid dependencies
  • From: John Kelly <jakelly@xxxxxxxx>
  • Date: Sun, 06 Mar 2005 14:54:58 -0500
  • Message-id: <33nm21t9p6k457j6kfbaoocnfqok9d36qs@xxxxxxx>
On Sun, 06 Mar 2005 15:02:59 +0100 (CET), Gabor Istvan
<suseuser04@xxxxxxxxxxx> wrote:

> SuSE has ... unnecessary dependencies.

And more with every new release it seems. I use grep and sed in a
shell script to strip the source rpm spec files down to essential
dependencies, then compile from source. It takes time, but I like
everything compiled from source (and i686 optimized), plus I can mix
updated packages from 9.2 with my 9.0 system / 2.4 kernel.

My login prompt even says Welcome to SuSE 9.x

Anyone know what version of gcc will be in suse 9.3? gcc 3.3.x is
unreliable with -O3, but gcc 3.4.x seems to produce correct output at
-O3, for what I have tested so far.



< Previous Next >