Mailinglist Archive: opensuse (3901 mails)

< Previous Next >
Re: [SLE] Help with new printer
  • From: Graham Smith <gqs@xxxxxxxxxxxx>
  • Date: Thu, 6 Jan 2005 01:08:08 +1100
  • Message-id: <200501060108.08336.gqs@xxxxxxxxxxxx>
On Wed, 5 Jan 2005 13:44, David Johanson wrote:
> Well, it's truly amazing what you can find once you get to the correct
> buried .pdf file and peruse through all 300+ pages of it. Buried in the
> middle is a discussion of HOW to assign an ip address to the printer, (I
> chose 192.168.0.6) which, when done, allows for communication with the
> printer.
>
> So now SuSE 9.2 can communicate with the printer and when asking for a text
> only output prints out a single sheet which reads:
> "This is the YaST2 ASCI test page
> Das ist die YaST2 ASCII Testseite
> Toto je ascii"
> across the page. However, trying to print out either graphic page, with or
> without photo, gives "%!" on the first line, "% license and copyright: SUSE
> Linux AG - YaST License" on the second line, and "% author: Johannes
> Meixne" on the third line, sans quotes of course. Then that page is
> followed by page after page of blank paper.
>
> Much progress in that we can now communicate and print text, but not sure
> as to the next step in getting the graphical stuff to print. Again, any
> suggestions greatly appreciated.

Looks like your ppd driver is wrong. Someone mentioned the printer supports
the PCL5c Language. I suggest you try setting the printer model to HP4 and
trying the different drivers.

Also you may have to dive into that 300+ page pdf file and see if there is
anything about switching/changing to PCL5c or HP emulation mode. They might
give you information on the model of the printer it emulates. If that is the
case use that model when configuring your printer with Yast.


--
Regards,

Graham Smith
---------------------------------------------------------

< Previous Next >
Follow Ups