Mailinglist Archive: opensuse (4020 mails)

< Previous Next >
Re: [SLE] XFree86 4.2.99 (4.4 rc2) SOLVED
  • From: Chadley Wilson <chadley@xxxxxxxxxxxx>
  • Date: Thu, 14 Oct 2004 15:48:08 +0200
  • Message-id: <200410141548.08796.chadley@xxxxxxxxxxxx>
On Thursday 14 October 2004 15:27, Jeffrey Laramie wrote:
> On Thursday 14 October 2004 04:40, Chadley Wilson wrote:
> > On Thursday 14 October 2004 10:21, Anders Johansson wrote:
> > > > > cd /lib/modules/2.6.5-7.108-default
> > > > > rm build
> > > > > ln -s /usr/src/linux-2.6.5-7.108 build
> > > > >
> > > > > After that it should work
> >
> > Thank you very much,
> > I realised what I was doing wrong.
> > Its working thanks
>
> Can you tell us what you did to fix it so that the archive shows the
> solution for the next person with this problem?
>
> Jeff

Sure
Thanks to Anders Johansson for the input
The error is here again as follows:
Running the rpm from the ATI website fglrx-4.3.0-3.14.1.i386.rpm

rpm -Uvh -force fglrx-4.3.0-3.14.1.i386.rpm
you youw will get an error:
That start with something about your card won't have 3D support,
There will be some intructions in that error see below. the rpm still reports
succesfull install.

=====================================
XFree86 drm includes
at /lib/modules/2.6.5-7.108-default/build/include/../driver
s/char/drm do not fit this driver.
This driver is designed to only work with X4.1.0 or higher.
You can match this by getting Linux kernel 2.4.8 or higher.
*** WARNING ***
Tailored kernel module for fglrx not present in your system.
You must go to /lib/modules/fglrx/build_mod subdir
and execute './make.sh' to build a fully customed kernel module.
Afterwards go to /lib/modules/fglrx and run './make_install.sh'
in order to install the module into your kernel's module repository.
(see readme.txt for more details.)
========================================

Only if you try following these instructions it won't compile.


Switch to init 3 and login as root if not already,
then read carefully as I did not the first time :-)
(this fix is posted by Anders Johansson, thank you Anders)


cd /lib/modules/2.6.5-7.108-default

rm build

ln -s /usr/src/linux-2.6.5-7.108 build

OK
Now just follow the instructions in the error above and it will work.
Don't forget to run fglrxconfig afterwards.

Cheers and good luck


--
Chadley Wilson
Redhat Certified Technician
Cert Number: 603004708291270
Pinnacle Micro
Manufacturers of Proline Computers
====================================
Exercise freedom, Use LINUX
=====================================

< Previous Next >