Mailinglist Archive: opensuse (3996 mails)

< Previous Next >
ifup script on SuSE 9.1 Pro
  • From: Grant Limberg <glimberg@xxxxxxxxx>
  • Date: Wed, 1 Sep 2004 01:01:16 -0400
  • Message-id: <848adeb2040831220170c40027@xxxxxxxxxxxxxx>
I'm trying to set up my SuSE 9.1 box as an open Access Point with
HostAP. Its all configured to load up the HostAP modules & they seem
to be working just fine but the ifup script doesnt seem to be working
for the interface. The interface doesnt start up on boot either. The
card is a D-Link DWL-520. When I do a 'ifup wlan0' i get the
following output:

# ifup wlan0
wlan0
ERROR: No configuration found for wlan0

yet in my /etc/sysconfig/network directory there's a config file for
my wireless card. (ifcfg-wlan-bus-pci-0000:01:07.0). Here's its
contents:

BOOTPROTO='static'
BROADCAST='10.6.0.255'
IPADDR='10.6.0.1'
MTU=''
NETMASK='255.255.255.0'
NETWORK='10.6.0.0'
REMOTE_IPADDR=''
STARTMODE='onboot'
UNIQUE='2_DJ.nKQKZ9PaRIC'
WIRELESS_AP=''
WIRELESS_AUTH_MODE='open'
WIRELESS_BITRATE='auto'
WIRELESS_CHANNEL='3'
WIRELESS_DEFAULT_KEY='0'
WIRELESS_ESSID='UseButDontAbuse'
WIRELESS_KEY=''
WIRELESS_KEY_0=''
WIRELESS_KEY_1=''
WIRELESS_KEY_2=''
WIRELESS_KEY_3=''
WIRELESS_KEY_LENGTH='128'
WIRELESS_MODE='Master'
WIRELESS_NICK=''
WIRELESS_NWID=''
WIRELESS_POWER='no'
_nm_name='bus-pci-0000:01:07.0'
WIRELESS_FREQUENCY='

Also, here's the output of iwconfig:

# iwconfig
lo no wireless extensions.

sit0 no wireless extensions.

eth0 no wireless extensions.

wlan0 IEEE 802.11b ESSID:"UseButDontAbuse"
Mode:Master Frequency:2.422GHz Access Point: 00:05:5D:F9:C6:83
Bit Rate:11Mb/s Sensitivity=1/3
Retry min limit:8 RTS thr:off Fragment thr:off
Encryption key:off
Power Management:off
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

wlan0ap IEEE 802.11b ESSID:"UseButDontAbuse"
Mode:Master Frequency:2.422GHz Access Point: 00:05:5D:F9:C6:83
Bit Rate:11Mb/s Sensitivity=1/3
Retry min limit:8 RTS thr:off Fragment thr:off
Encryption key:off
Power Management:off

wlan0sta IEEE 802.11b ESSID:"UseButDontAbuse"
Mode:Managed Frequency:2.422GHz Access Point: 00:00:00:00:00:00
Bit Rate:11Mb/s Sensitivity=1/3
Retry min limit:8 RTS thr:off Fragment thr:off
Encryption key:off
Power Management:off

Am I missing something or is the ifup script not working right, and
how can I get it working?

Thanks in advance.
--
Grant Limberg
GPG Key:
http://pgp.mit.edu:11371/pks/lookup?op=get&search=0x8C8E3D99

< Previous Next >
Follow Ups