Mailinglist Archive: opensuse (5100 mails)

< Previous Next >
Re: [SLE] Send Fax per network not possible?
  • From: Louis Richards <louis@xxxxxxxxxxxxxxxxxx>
  • Date: Sun, 27 Jun 2004 03:17:06 -0400
  • Message-id: <40DE7472.8000900@xxxxxxxxxxxxxxxxxx>
Greg Engel wrote:

On Saturday 26 June 2004 6:47 pm, Laurent wrote:


I'd like to send an OpenOffice 1.1.1 over the LAN (as I have no other
choice...) to a normal fax number. The Problem is the printer
configuration of OpenOffice.org: when adding a fax device, I have to
enter some commands with some strings. But i don't know what they want
me to enter... Clicking


My notes say: sendfax -s na-let -n -d(PHONE) (TMP)
Give that a try. I assume you already have tested sending a fax from the command line to verify that works.

Greg Engel

I would make sure that Hylafax is set up to allow your host by looking at "/var/spool/fax/etc/hosts.hfaxd" on the fax server. Check out "man hosts.hfaxd" for the format.

On the clients, I set up OpenOffice to print to kprinter. This provides a list of all printers as well as a "print to fax" option. The fax option opens "kdeprintfax". The first time you run it go to "Settings -> Configure KdeprintFax". From there choose "System" on the left and change it from "EFax" to "Hylafax". The default command string of "/usr/bin/sendfax -n -h %server %res %time_a -x %enterprise -c %comment -f %email -d %name@%number %files" should be fine. Then add the name/ip address of the server and click OK.

This is what I have done and my clients are faxing without any trouble. The only thing I have changed was to add the "-D" option to the command line. This sends the sender an email when the fax is sent as well as when it fails.

Louis


< Previous Next >