Mailinglist Archive: opensuse (2271 mails)

< Previous Next >
Courier IMAP and SuSE 9.0 Pro GDBM issue
  • From: Ahbaid Gaffoor <ahbaid@xxxxxxx>
  • Date: Mon, 12 Apr 2004 18:07:11 -0500
  • Message-id: <407B211F.5010501@xxxxxxx>
Hello all,

I am using qmail with Maildir directories
I need to install Courier IMAP to support web based email,
however when attempting to configure I am getting the classic:

"configure: error: Cannot find either the gdbm or the db library."

I am trying to install courier-imap-3.0.3.tar.gz on SuSE 9.0 Professional (2.4.20-64GB-SMP)

I did an "rpm -qa | grep gdbm" and the results were as follows:
gdbm-1.8.3-33

I then issued a "rpm -ql gdbm-1.8.3-33" and the results were:
/usr/lib/libgdbm.so.3
/usr/lib/libgdbm.so.3.0.0
/usr/lib/libgdbm_compat.so.3
/usr/lib/libgdbm_compat.so.3.0.0
/usr/share/doc/packages/gdbm
/usr/share/doc/packages/gdbm/COPYING
/usr/share/doc/packages/gdbm/NEWS
/usr/share/doc/packages/gdbm/README


I also tried setting CPPFLAGS="-I/usr/lib" and LDFLAGS="-L/usr/lib"
but the same error arises.

I also checked with "ldconfig -p | grep gdbm" and got:
libgdbm_compat.so.3 (libc6) => /usr/lib/libgdbm_compat.so.3
libgdbm.so.3 (libc6) => /usr/lib/libgdbm.so.3
libgdbm.so.2 (libc6) => /usr/lib/libgdbm.so.2


The SuSE 9 RPM for courier I have is: courier-imap-2.1.1-29.i586.rpm

but this needs: libcrypto.so.0.9.7 is needed by courier-imap-2.1.1-29
libssl.so.0.9.7 is needed by courier-imap-2.1.1-29

when I attempt "rpm -ivh courier-imap-2.1.1-29.i586.rpm"

I then tried to freshen openssl with "rpm -F openssl-0.9.7b-68.i586.rpm" but received a long list of " libssl.so.0.9.6 is needed by ...." messages

How do I install courier IMAP under SuSE 9?

I guess the real issue is getting the config to see the existing gdbm libraries. But isn't this taken care of by ldconfig?

Any thoughts or suggestions are welcome

kind regards

Ahbaid



< Previous Next >