Mailinglist Archive: opensuse (3470 mails)

< Previous Next >
Compilation failing - can't find gtk+ >=2.0.0
  • From: John Pettigrew <john@xxxxxxxxxxxxxxxx>
  • Date: Thu, 4 Sep 2003 15:44:24 +0100
  • Message-id: <gemini.3f574fc8005b1850%john@xxxxxxxxxxxxxxxx>
I seem not to be able to compile gtk apps on my system. The failure is like
this (from a compilation of GPA, the configure script):

...
checking for pkg-config... /usr/bin/pkg-config
checking for GTK+ - version >= 2.0.0... no
*** Could not run GTK+ test program, checking why...
*** The test program failed to compile or link. See the file config.log for
the
*** exact error that occured. This usually means GTK+ is incorrectly
installed.
configure: error: Cannot find GTK+ 2.0




config.log contains the following:

configure:8435: checking for GTK+ - version >= 2.0.0
configure:8582: result: no
configure:8616: gcc -o conftest -g -O2 conftest.c -lz -lm >&5
configure:8673:21: gtk/gtk.h: No such file or directory
configure: In function `main':
configure:8679: error: `gtk_major_version' undeclared (first use in this
function)
configure:8679: error: (Each undeclared identifier is reported only once
configure:8679: error: for each function it appears in.)
configure:8679: error: `gtk_minor_version' undeclared (first use in this
function)
configure:8679: error: `gtk_micro_version' undeclared (first use in this
function)
configure:8619: $? = 1
configure: failed program was:
| #line 8596 "configure"
| /* confdefs.h. */
|
| #define PACKAGE_NAME "gpa"
| #define PACKAGE_TARNAME "gpa"
| #define PACKAGE_VERSION "0.6.1"
| #define PACKAGE_STRING "gpa 0.6.1"
| #define PACKAGE_BUGREPORT "bug-gpa@xxxxxxxxx"
| #define PACKAGE "gpa"
| #define VERSION "0.6.1"
| #define PACKAGE "gpa"
| #define VERSION "0.6.1"
| #define PACKAGE_BUGREPORT "bug-gpa@xxxxxxxxx"
| #define HAVE_LIBM 1
| #define HAVE_LIBZ 1
| #define HAVE_STRSEP 1
| #define STDC_HEADERS 1
| #define GPG_PATH "/usr/local/bin/gpg"
| #define HAVE_SYS_TYPES_H 1
| #define HAVE_SYS_STAT_H 1
| #define HAVE_STDLIB_H 1
| #define HAVE_STRING_H 1
| #define HAVE_MEMORY_H 1
| #define HAVE_STRINGS_H 1
| #define HAVE_INTTYPES_H 1
| #define HAVE_STDINT_H 1
| #define HAVE_UNISTD_H 1
| #define HAVE_ALLOCA_H 1
| #define HAVE_ALLOCA 1
| #define HAVE_STDLIB_H 1
| #define HAVE_UNISTD_H 1
| #define HAVE_GETPAGESIZE 1
| #define HAVE_MMAP 1
| #define INTDIV0_RAISES_SIGFPE 1
| #define HAVE_INTTYPES_H_WITH_UINTMAX 1
| #define HAVE_STDINT_H_WITH_UINTMAX 1
| #define HAVE_UNSIGNED_LONG_LONG 1
| #define HAVE_INTTYPES_H 1
| #define HAVE_ARGZ_H 1
| #define HAVE_LIMITS_H 1
| #define HAVE_LOCALE_H 1
| #define HAVE_NL_TYPES_H 1
| #define HAVE_MALLOC_H 1
| #define HAVE_STDDEF_H 1
| #define HAVE_STDLIB_H 1
| #define HAVE_STRING_H 1
| #define HAVE_UNISTD_H 1
| #define HAVE_SYS_PARAM_H 1
| #define HAVE_FEOF_UNLOCKED 1
| #define HAVE_FGETS_UNLOCKED 1
| #define HAVE_GETC_UNLOCKED 1
| #define HAVE_GETCWD 1
| #define HAVE_GETEGID 1
| #define HAVE_GETEUID 1
| #define HAVE_GETGID 1
| #define HAVE_GETUID 1
| #define HAVE_MEMPCPY 1
| #define HAVE_MUNMAP 1
| #define HAVE_PUTENV 1
| #define HAVE_SETENV 1
| #define HAVE_SETLOCALE 1
| #define HAVE_STPCPY 1
| #define HAVE_STRCASECMP 1
| #define HAVE_STRDUP 1
| #define HAVE_STRTOUL 1
| #define HAVE_TSEARCH 1
| #define HAVE___ARGZ_COUNT 1
| #define HAVE___ARGZ_STRINGIFY 1
| #define HAVE___ARGZ_NEXT 1
| #define HAVE_ICONV 1
| #define ICONV_CONST
| #define HAVE_LANGINFO_CODESET 1
| #define HAVE_LC_MESSAGES 1
| #define ENABLE_NLS 1
| #define HAVE_GETTEXT 1
| #define HAVE_DCGETTEXT 1
| /* end confdefs.h. */
|
| #include <gtk/gtk.h>
| #include <stdio.h>
|
| int
| main ()
| {
| return ((gtk_major_version) || (gtk_minor_version) || (gtk_micro_version));
| ;
| return 0;
| }
configure:8650: error: Cannot find GTK+ 2.0


I'm sure I must have missed something obvious, but I'm blowed if I can see it!

Thanks for any help

John
--
John Pettigrew Headstrong Games
john@xxxxxxxxxxxxxxxxxxxxxx Fun : Strategy : Price
http://www.headstrong-games.co.uk/ Board games that won't break the bank

< Previous Next >