Mailinglist Archive: opensuse (4749 mails)

< Previous Next >
Re: [SLE] perl-XML-libXML?
  • From: Curtis Rey <crrey@xxxxxxxxxxx>
  • Date: Fri, 2 May 2003 22:13:18 -0500
  • Message-id: <200305022213.27758.crrey@xxxxxxxxxxx>
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

On Thursday 01 May 2003 16:32, Togan Muftuoglu wrote:
> * Curtis Rey; <crrey@xxxxxxxxxxx> on 30 Apr, 2003 wrote:
> >-----BEGIN PGP SIGNED MESSAGE-----
> >Hash: SHA1
> >
> >I need to install the perl-XML-libXML packages but it isn't included in
> > the SuSE 8.1 discs and I am unsure what package provides it or if I can
> > find it as a independent/stand-alone packages.
> >
> >Does anyone know where/how I can find this lib?
>
> type the following in a term (console Xterm mlterm)
>
> $ perl -MCPAN -e shell;
>
> ( if you have not configured CPAN it will ask couple of questions if you
> answer prerequisites_policy "follow" CPAN will get the necessary
> packages for you. )
> type
>
> cpan> i XML::LibXML
>
> this will give you the information about the package
>
> cpan> make XML::LibXML
>
> will get the package along with the missing parts also if you look to
> CPAN documentation "man CPAN" you can have other info as howto install
> packages as user.
>
>
> Alternatively get cpan2rpm from ftp://dinamizm.ath.cx so you can build
> RPMS of the packages (note that cpan2rpm also depends on your cpan
> configuration)

Ok, Looks like this program could seriously rock. However, I ran across this
when doing a cpan> install XML::LibXML

t/19encoding.....skipped
all skipped: no reason given
t/20extras.......ok
t/22iterator.....ok
Failed Test Stat Wstat Total Fail Failed List of Failed
- -------------------------------------------------------------------------------
t/08findnodes.t 0 11 18 13 72.22% 6-18
2 tests skipped.
Failed 1/21 test scripts, 95.24% okay. 13/563 subtests failed, 97.69% okay.
make: *** [test_dynamic] Error 29
/usr/bin/make test -- NOT OK
Running make install
make test had returned bad status, won't install without force

cpan>

When I follow the instructions you gave me it created a dir "/root/.cpan" and
put the files there. So, of course, using the "install" flag for the libs
went straight to the .cpan dir and found what it was looking for. So,
question. Do I try re-get and then install (due to possible bad download) or
use the "force" flag?

Cheers, Curtis :)
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.0.7 (GNU/Linux)

iD8DBQE+szPW7WVLiDrqeksRAhrMAJ9FiKGFblLIdmw5cWLJffgogRvoPgCeJuui
vN+udEjk8zdg6YepCjQLbpk=
=+g7h
-----END PGP SIGNATURE-----


< Previous Next >
References