Mailinglist Archive: opensuse (3103 mails)

< Previous Next >
Re: [SLE] libxml2 and xmlcatalog
  • From: Anders Johansson <andjoh@xxxxxxxxxx>
  • Date: Thu, 20 Feb 2003 04:31:55 +0100
  • Message-id: <200302200431.55909.andjoh@xxxxxxxxxx>
On Thursday 20 February 2003 04:28, L. Mark Stone wrote:
> I'm trying to update my SuSE 8.1 system to KDE 3.1 using YaST2. I've
> configured YaST2 no problem, but I am getting a dependency failure when
> trying to update libxml2.
>
> YaST reports that libxml2 2.5.1-1 conflicts with docbook_4 and
> scrollkeeper, which require xmlcatalog.
>
> But a listing of the files inside the libxml2 rpm clearly shows that
> /usr/bin/xmlcatalog is there.?!

It's not really what is actually in the rpm, it's a question of what the rpm
claims it provides. I guess the old version of libxml that you're upgrading
had a "Provides: xmlcatalog".

If that is the only error, I guess --nodeps is fine.

But *never* use the --force

regards
Anders

< Previous Next >
Follow Ups
References