Mailinglist Archive: opensuse (4288 mails)

< Previous Next >
Re: [SLE] KDE 3.0.1 + YaST2 = no more online updates :-(
  • From: Andy Stewart <andystewart@xxxxxxxxx>
  • Date: Mon, 27 May 2002 23:19:17 -0400
  • Message-id: <200205272319.17709.andystewart@xxxxxxxxx>
On Monday 27 May 2002 11:20 pm, Travis Owens wrote:
> On Mon, 2002-05-27 at 22:06, Andy Stewart wrote:
> > Hi everybody,
> >
> > After upgrading to KDE 3.0.1 with the packages in the supplementary
> > directories, YaST2 no longer works properly in every case.
> >
> > When I attempt to use the online update from YaST2 with KDE running,
> > after typing my root password, a portion of the YaST2 window eventually
> > turns grey (instead of showing the online update). I see the following
> > error messages back at my console window (the one from which I originally
> > started X):
> >
> > Undefined symbol init_libkcm_yast2 in /opt/kde3/lib/libkdecore.so.4
> > The library libkcm_yast2 does not offer an init_libkcm_yast2 function
>
> Ok, it sounds like you d/l-ed the packages from the ftp server and
> manually installed the updates?

Yes, that's precisely what I did.

>
> If so, did you run SuSEconfig and ldconfig after to sync the libraries?

Yes. I also double checked that /opt/kde3/lib was listed in /etc/ld.so.conf.

>
> Just a thought.

Good try - thanks!

>
> Travis.

Here is more detailed info:

kdecore (KLibLoader): WARNING: KLibrary: /opt/kde3/lib/libkdecore.so.4:
undefined symbol: init_libkcm_yast2
kdecore (KLibLoader): WARNING: KLibrary: The library libkcm_yast2 does not
offer an init_libkcm_yast2 function
ASSERT: "!name.isEmpty()" in kinstance.cpp (55)

--
Andy Stewart, Founder
Worcester Linux Users' Group
Worcester, MA USA
http://www.wlug.org


< Previous Next >