Mailinglist Archive: opensuse (3784 mails)

< Previous Next >
Re: [SLE] Upgrade Kernel In SuSe 6.0 from 2.0.36 to 2.4.12
  • From: Bruce Marshall <bmarsh@xxxxxxxxxx>
  • Date: Tue, 23 Oct 2001 09:08:40 -0400
  • Message-id: <200110231308.f9ND8e417963@xxxxxxxxxxxxxxxxx>
On Tuesday 23 October 2001 6:44 am, John Mc Cabe wrote:
> Hi out there,
>
> I have a few questions......
>
> 1. I have SuSe Linux 6.0 running a custom application. I have to increase
> the amount of open files that the program uses but when i use the
> ulimit -n command it returns an error saying operation not permitted. is
> there any other way without rebuilding or upgrading the kernel that i can
> increase this value?.
>
> 2. If i have to rebuild the kernel to support this new value what source
> files do i have to modify?
>
> 3. if i have to upgrade the kernel what exactly do i need to do it on SuSe
> 6.0? I have downloaded 2.4.12 and all the updates for SuSe 6.0
>
> 4. Would it be easier to upgrade to a later version and does the later
> version allow me to increase the amount of open files?
>
>
> Any help regarding these questions would be grately appreiciated.
>
>
> Regards
>
> John Mc Cabe

I would not recommend upgrading your kernel from 2.0.x to anything 2.4.x
There are many pieces of the system which would have to change and you would
have to upgrade all of them. Going to a later version of SuSE would be the
preferred method.






--
+----------------------------------------------------------------------------+
+ Bruce S. Marshall bmarsh@xxxxxxxxxx Bellaire, MI 10/23/01 09:06 +
+----------------------------------------------------------------------------+
"We are not punished for our sins, but by them."

< Previous Next >
References