Mailinglist Archive: opensuse (2629 mails)

< Previous Next >
Re: [SLE] mounting floppy drive - thanks. works well now.[nt]
  • From: pras@xxxxxxxx (Prasanna Krishnan)
  • Date: Sat, 06 May 2000 21:38:49 -0400
  • Message-id: <3914C929.6ADF9771@xxxxxxxx>



Stefan Troeger wrote:

> Hi,
>
> On Sat, May 06 2000 at 19:33 -0400, Prasanna Krishnan wrote:
>
> > I tried your solution but it did not work. I don't know why. I checked the SuSE
> > online database and they had the same solution as you did. Could the problem be
> > the fact that I am using secure file permissions (YaST setting)?
>
> Yes, that's the problem. In order to let non-root users mount
> drives the mount binary has to be suid root, but setting
> permissions to secure removes the suid bit from /bin/mount. You
> can easily fix it like this:
>
> chown root.root /bin/mount /bin/umount
> chmod 4755 /bin/mount /bin/umount
>
> To prevent SuSEconfig from removing the suid bit again, add
>
> /bin/mount root.root 4755
> /bin/umount root.root 4755
>
> to /etc/permissions.local.
>
> Ciao,
> Stefan
>
> In your first mail you mentioned that you added yourself to the
> disk group. Don't do that as accidently redirecting some program
> output to your harddisk device will have disastrous results if
> you're in that group.
>
> --
> To unsubscribe send e-mail to suse-linux-e-unsubscribe@xxxxxxxx
> For additional commands send e-mail to suse-linux-e-help@xxxxxxxx
> Also check the FAQ at http://www.suse.com/Support/Doku/FAQ/


--
To unsubscribe send e-mail to suse-linux-e-unsubscribe@xxxxxxxx
For additional commands send e-mail to suse-linux-e-help@xxxxxxxx
Also check the FAQ at http://www.suse.com/Support/Doku/FAQ/


< Previous Next >
References