Mailinglist Archive: opensuse (3222 mails)

< Previous Next >
Re: [SLE] wrong mysql dependencies?
  • From: grimmer@xxxxxxx (Lenz Grimmer)
  • Date: Tue, 15 Feb 2000 18:36:50 +0100 (MET)
  • Message-id: <Pine.LNX.4.21.0002151836070.2283-100000@xxxxxxxxxxxxx>



Hi,

On Tue, 15 Feb 2000, Omar Armas Aleman wrote:

> > > soporte:~/rpm # rpm -q mysql
> > > mysql-3.22.27-11
> > > soporte:~/rpm # rpm -Uvh --force mysqldev-3.22.27-11.i386.rpm
> > > error: failed dependencies:
> > > mysqclnt is needed by mysqldev-3.22.27-11
> > > soporte:~/rpm # rpm -Uvh --force mysqclnt-3.22.27-11.i386.rpm
> > > error: failed dependencies:
> > > libmysqlclient.so.6 is needed by mysqclnt-3.22.27-11
> > > soporte:~/rpm #
> >
> > No, this is normal. libmysqlclient belongs to the mysqldev
> > package. Install this one as well.
>
> Yes, but if you see above i cannot install mysqldev because it says it
> needs mysqclnt. A loop? What am i doing wrong?

Nothing. Just install all mysql RPMs at once (in one command line), or
use "--nodeps" instead of "--force."

Bye,
LenZ


--
------------------------------------------------------------------
Lenz Grimmer SuSE GmbH
mailto:grimmer@xxxxxxx Schanzaeckerstr. 10
http://www.suse.de/~grimmer 90443 Nuernberg, Germany

--
To unsubscribe send e-mail to suse-linux-e-unsubscribe@xxxxxxxx
For additional commands send e-mail to suse-linux-e-help@xxxxxxxx
Also check the FAQ at http://www.suse.com/Support/Doku/FAQ/


< Previous Next >
Follow Ups
References