Mailinglist Archive: opensuse-virtual (33 mails)

< Previous Next >
[opensuse-virtual] help launching a Centos 5.5 Xen PV guest on an OpenSuse 11.2 Dom0 host ?
  • From: 0bo0 <0.bugs.only.0@xxxxxxxxx>
  • Date: Wed, 2 Jun 2010 20:01:51 -0700
  • Message-id: <AANLkTikUC1C8iiuJ3ahqM6b5hceV-lZDnapPF54cBfaA@xxxxxxxxxxxxxx>
i've Opensuse 11.2 Xen Dom0,

lsb_release -dr
Description: openSUSE 11.2 (x86_64)
Release: 11.2

uname -a
Linux server 2.6.34-42-xen #1 SMP 2010-06-01 15:17:00 +0200
x86_64
x86_64 x86_64 GNU/Linux


rpm -qa | grep -i xen
xen-libs-4.0.0_21087_01-38.1.x86_64
kernel-xen-devel-2.6.34-42.1.x86_64
xen-tools-4.0.0_21087_01-38.1.x86_64
kernel-xen-2.6.34-42.1.x86_64
xen-4.0.0_21087_01-38.1.x86_64

I build & run numerous OpenSuse DomUs -- no issues.

I need to netinstall a Centos 5.5 PV'd DomU Guest on this host.

Using the procedure & config below, it starts to boot -- then hangs,
with not much useful debugging info ... at least, not to my eye,
where/how I'm looking.

If someone could once-over the following, and make any
suggestions/hints as to what's up, it'd be appreciated!

Here's the current step-by-step:

lvcreate -n vm_boot -L 160M /dev/VG0
lvcreate -n vm_swap -L 512M /dev/VG0
lvcreate -n vm_root -L 8G /dev/VG0

mkdir -p /home/xen/centos55/xenboot/

setenv DL "http://mirrors.kernel.org/centos/5.5";
cd /home/xen/centos55
wget $DL/isos/x86_64/CentOS-5.5-x86_64-netinstall.iso
cd ./xenboot/
wget $DL/os/x86_64/images/xen/initrd.img
wget $DL/os/x86_64/images/xen/vmlinuz

vi /home/xen/centos_install.cfg
---------------------------------------------
name = 'centos'
builder = 'linux'
kernel = "/home/xen/centos55/xenboot/vmlinuz"
ramdisk = "/home/xen/centos55/xenboot/initrd.img"
disk = [ 'phy:/dev/VG0/vm_boot,xvda,w',
'phy:/dev/VG0/vm_swap,xvdb,w',
'phy:/dev/VG0/vm_root,xvdc,w',

'file:/home/xen/centos55/CentOS-5.5-x86_64-netinstall.iso,hdc:cdrom,r',
]
boot = 'd'
vif = [ 'mac=00:16:3E:01:06:00, bridge=brA, vifname=vif.A' ]
vfb = [ 'type=vnc, vncdisplay=106, vnclisten=127.0.0.1' ]
extra = 'textmode=1 xencons=xvc0 elevator=noop lang=en_US.UTF-8
keyboard=us timezone=America/Los_Angeles bootproto=static
ip=192.168.1.155 gateway=192.168.1.1 nameserver=192.168.1.1
method=http://mirrors.kernel.org/centos/5.5/os/x86_64'

maxmem = 1024
memory = 1024
vcpus = 4
cpu_cap = 100
cpu_weight = 256
localtime = 0
netif = 'yes'
on_shutdown = 'destroy'
on_reboot = 'restart'
on_crash = 'destroy'
---------------------------------------------

@

xm create -c /home/xen/centos_install.cfg

starts ok, but then hangs,

---------------------------------------------
Using config file "/home/xen/centos_install.cfg".
Started domain centos (id=5)
Bootdata ok (command line is textmode=1
xencons=xvc0 elevator=noop lang=en_US.UTF-8 keyboard=us
timezone=America/Los_Angeles bootproto=static ip=192.168.1.155
gateway=192.168.1.1 nameserver=192.168.1.1
method=http://mirrors.kernel.org/centos/5.5/os/x86_64)
Linux version 2.6.18-194.el5xen (mockbuild@xxxxxxxxxxxxxxxxxxxx) (gcc
version 4.1.2 20080704 (Red Hat 4.1.2-48)) #1 SMP Fri Apr 2 15:34:40
EDT 2010
...
XENBUS: Device with no driver: device/vif/1
XENBUS: Device with no driver: device/vif/2
XENBUS: Device with no driver: device/vif/3
XENBUS: Device with no driver: device/console/0
Initalizing network drop monitor service
Write protecting the kernel read-only data: 483k

( ... HANGS HERE ...)
---------------------------------------------

and,

tail -f /var/logl/xen/*

---------------------------------------------
...
[2010-06-02 19:46:17 4832] DEBUG (DevController:653)
hotplugStatusCallback
/local/domain/0/backend/vbd/5/51744/hotplug-status.
[2010-06-02 19:46:17 4832] DEBUG (DevController:667) hotplugStatusCallback 1.
[2010-06-02 19:46:17 4832] DEBUG (DevController:144) Waiting for 5632.
[2010-06-02 19:46:17 4832] DEBUG (DevController:653)
hotplugStatusCallback
/local/domain/0/backend/vbd/5/5632/hotplug-status.
[2010-06-02 19:46:17 4832] DEBUG (DevController:667) hotplugStatusCallback 1.
[2010-06-02 19:46:18 4832] DEBUG (DevController:139) Waiting for devices irq.
[2010-06-02 19:46:18 4832] DEBUG (DevController:139) Waiting for devices vfb.
[2010-06-02 19:46:18 4832] DEBUG (DevController:139) Waiting for devices pci.
[2010-06-02 19:46:18 4832] DEBUG (DevController:139) Waiting for devices vusb.
[2010-06-02 19:46:18 4832] DEBUG (DevController:139) Waiting for devices vtpm.
[2010-06-02 19:46:18 4832] INFO (XendDomain:1207) Domain centos (5) unpaused.

( ... HANGS HERE ...)
---------------------------------------------
--
To unsubscribe, e-mail: opensuse-virtual+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-virtual+help@xxxxxxxxxxxx

< Previous Next >
List Navigation
Follow Ups