Mailinglist Archive: opensuse-virtual (12 mails)

< Previous Next >
[opensuse-virtual] xen/kernel-xen on OS 11.1 not starting; OK on 11.0
  • From: PGNet <pgnet.trash+osvm@xxxxxxxxx>
  • Date: Sat, 20 Dec 2008 11:05:37 -0800
  • Message-id: <dbd51810812201105o545921daxa0c2b0b00d58a03e@xxxxxxxxxxxxxx>
i've been successfully running a headless install of OpenSuse 11.0 + Xen 321 as
a Xen Dom0 w/ multiple DomUs for quite awhile ...

i just built up a new OpenSuse 11.1 + Xen 331 box.
short story -- not working, and not clear as to why not, yet.

i've partitioned, as always, as RAID-1 across two disks,

sda + sdb, each
part1 150 MB, LinuxRaid
part2 10 GB, LinuxRaid
part3 *, LinuxRaid

/dev/md0 = sda1 + sdb1, mount_pt = '/boot', ext3
/dev/md1 = sda2 + sdb2
Volume Group "System"
Logical Volume "Swap", mount_pt = 'swap', 512 MB,
Logical Volume "Root", mount_pt = '/', *
/dev/md2 = sda3 + sdb3

with this setup, boot to non-xen kernel works perfectly, as it did on
OpenSuse 11.0,

uname -a
Linux server #1 SMP 2008-12-04 18:10:04
+0100 x86_64
x86_64 x86_64 GNU/Linux
lsb_release -r
Release: 11.1

i've installed

zypper in -t pattern xen-server
rpm -qa | grep -i xen

on attempt to boot to xen kernel, it fails ...

@ boot console I see mention of '/var' not available scroll quickly by, and
something about fsck.ext3 failing ... then i'm dumped @ a console prompt.

i *can* login, but ...

/var exists and is populated, but nothing is written to /var/log/xen/xend.log
or /var/log/messages.

/boot exists, but is completely empty (?).

rebooting, I can get back to non-xen kernel and all is ok again.


service xend start

returns simply

xend unused

not sure if this is informative,

ERROR Internal error: Could not obtain handle on privileged
command interface
(2 = No such file or directory)
Traceback (most recent call last):
File "/usr/sbin/xend", line 44, in <module>
from xen.xend.server import SrvDaemon
line 26, in <module>
import relocate
"/usr/lib64/python2.6/site-packages/xen/xend/server/", line
28, in <module>
from xen.xend import XendDomain
"/usr/lib64/python2.6/site-packages/xen/xend/", line 35,
in <module>
from xen.xend import XendOptions, XendCheckpoint,
"/usr/lib64/python2.6/site-packages/xen/xend/", line
20, in <module>
from xen.xend import balloon, sxp, image
File "/usr/lib64/python2.6/site-packages/xen/xend/",
line 44, in
xc = xen.lowlevel.xc.xc()
xen.lowlevel.xc.Error: (1, 'Internal error', 'Could not obtain
handle on
privileged command interface (2 = No such file or directory)')

something's changed between 11.0 & 11.1. entirely possible i've missed some new
config req'ts.

what do I need to do to get xen behaving under 11.1?

i'm happy to provide any info -- just need some guidance as to where to look ...
To unsubscribe, e-mail: opensuse-virtual+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-virtual+help@xxxxxxxxxxxx

< Previous Next >
List Navigation
Follow Ups