Mailinglist Archive: opensuse-updates (126 mails)

< Previous Next >
openSUSE-SU-2018:0159-1: moderate: Security update for ncurses
openSUSE Security Update: Security update for ncurses
______________________________________________________________________________

Announcement ID: openSUSE-SU-2018:0159-1
Rating: moderate
References: #1056127 #1056128 #1056129 #1056131 #1056132
#1056136
Cross-References: CVE-2017-13728 CVE-2017-13729 CVE-2017-13730
CVE-2017-13731 CVE-2017-13732 CVE-2017-13733

Affected Products:
openSUSE Leap 42.3
openSUSE Leap 42.2
______________________________________________________________________________

An update that fixes 6 vulnerabilities is now available.

Description:

This update for ncurses fixes the following issues:

Security issues fixed:

- CVE-2017-13728: Fix infinite loop in the next_char function in
comp_scan.c (bsc#1056136).
- CVE-2017-13730: Fix illegal address access in the function
_nc_read_entry_source() (bsc#1056131).
- CVE-2017-13733: Fix illegal address access in the fmt_entry function
(bsc#1056127).
- CVE-2017-13729: Fix illegal address access in the _nc_save_str
(bsc#1056132).
- CVE-2017-13732: Fix illegal address access in the function dump_uses()
(bsc#1056128).
- CVE-2017-13731: Fix illegal address access in the function
postprocess_termcap() (bsc#1056129).

This update was imported from the SUSE:SLE-12:Update update project.


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.3:

zypper in -t patch openSUSE-2018-55=1

- openSUSE Leap 42.2:

zypper in -t patch openSUSE-2018-55=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.3 (i586 x86_64):

libncurses5-5.9-62.1
libncurses5-debuginfo-5.9-62.1
libncurses6-5.9-62.1
libncurses6-debuginfo-5.9-62.1
ncurses-debugsource-5.9-62.1
ncurses-devel-5.9-62.1
ncurses-devel-debuginfo-5.9-62.1
ncurses-utils-5.9-62.1
ncurses-utils-debuginfo-5.9-62.1
tack-5.9-62.1
tack-debuginfo-5.9-62.1
terminfo-5.9-62.1
terminfo-base-5.9-62.1

- openSUSE Leap 42.3 (x86_64):

libncurses5-32bit-5.9-62.1
libncurses5-debuginfo-32bit-5.9-62.1
libncurses6-32bit-5.9-62.1
libncurses6-debuginfo-32bit-5.9-62.1
ncurses-devel-32bit-5.9-62.1
ncurses-devel-debuginfo-32bit-5.9-62.1

- openSUSE Leap 42.2 (i586 x86_64):

libncurses5-5.9-55.9.1
libncurses5-debuginfo-5.9-55.9.1
libncurses6-5.9-55.9.1
libncurses6-debuginfo-5.9-55.9.1
ncurses-debugsource-5.9-55.9.1
ncurses-devel-5.9-55.9.1
ncurses-devel-debuginfo-5.9-55.9.1
ncurses-utils-5.9-55.9.1
ncurses-utils-debuginfo-5.9-55.9.1
tack-5.9-55.9.1
tack-debuginfo-5.9-55.9.1
terminfo-5.9-55.9.1
terminfo-base-5.9-55.9.1

- openSUSE Leap 42.2 (x86_64):

libncurses5-32bit-5.9-55.9.1
libncurses5-debuginfo-32bit-5.9-55.9.1
libncurses6-32bit-5.9-55.9.1
libncurses6-debuginfo-32bit-5.9-55.9.1
ncurses-devel-32bit-5.9-55.9.1
ncurses-devel-debuginfo-32bit-5.9-55.9.1


References:

https://www.suse.com/security/cve/CVE-2017-13728.html
https://www.suse.com/security/cve/CVE-2017-13729.html
https://www.suse.com/security/cve/CVE-2017-13730.html
https://www.suse.com/security/cve/CVE-2017-13731.html
https://www.suse.com/security/cve/CVE-2017-13732.html
https://www.suse.com/security/cve/CVE-2017-13733.html
https://bugzilla.suse.com/1056127
https://bugzilla.suse.com/1056128
https://bugzilla.suse.com/1056129
https://bugzilla.suse.com/1056131
https://bugzilla.suse.com/1056132
https://bugzilla.suse.com/1056136


< Previous Next >
This Thread
  • No further messages