Mailinglist Archive: opensuse-updates (117 mails)

< Previous Next >
openSUSE-SU-2017:0649-1: moderate: Security update for sane-backends
openSUSE Security Update: Security update for sane-backends
______________________________________________________________________________

Announcement ID: openSUSE-SU-2017:0649-1
Rating: moderate
References: #1027197
Cross-References: CVE-2017-6318
Affected Products:
openSUSE Leap 42.1
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:


This update for sane-backends fixes the following issues:

- saned could have leaked uninitialized memory back to its requesters for
some
opcodes, allowing for information disclosure of saned memory
(CVE-2017-6318, bsc#1027197).


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.1:

zypper in -t patch openSUSE-2017-318=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.1 (i586 x86_64):

sane-backends-1.0.24-5.1
sane-backends-autoconfig-1.0.24-5.1
sane-backends-debuginfo-1.0.24-5.1
sane-backends-debugsource-1.0.24-5.1
sane-backends-devel-1.0.24-5.1

- openSUSE Leap 42.1 (x86_64):

sane-backends-32bit-1.0.24-5.1
sane-backends-debuginfo-32bit-1.0.24-5.1


References:

https://www.suse.com/security/cve/CVE-2017-6318.html
https://bugzilla.suse.com/1027197


< Previous Next >
This Thread
  • No further messages