Mailinglist Archive: opensuse-updates (180 mails)

< Previous Next >
openSUSE-SU-2017:0072-1: moderate: Security update for gstreamer-plugins-bad
openSUSE Security Update: Security update for gstreamer-plugins-bad
______________________________________________________________________________

Announcement ID: openSUSE-SU-2017:0072-1
Rating: moderate
References: #1010829 #1013659 #1013678 #1013680
Cross-References: CVE-2016-9445 CVE-2016-9446 CVE-2016-9809
CVE-2016-9812 CVE-2016-9813
Affected Products:
openSUSE Leap 42.2
______________________________________________________________________________

An update that fixes 5 vulnerabilities is now available.

Description:

This update for gstreamer-plugins-bad fixes the following security issues,
which would allow attackers able to submit media files for indexing to
cause code execution or crashes:

- Check an integer overflow (CVE-2016-9445) and initialize a buffer
(CVE-2016-9446) in vmncdec. (bsc#1010829)
- CVE-2016-9809: Ensure codec_data has the right size when reading number
of SPS (bsc#1013659).
- CVE-2016-9812: Add more section size checks (bsc#1013678).
- CVE-2016-9813: fix PAT parsing (bsc#1013680).

This update was imported from the SUSE:SLE-12-SP2:Update update project.


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.2:

zypper in -t patch openSUSE-2017-63=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.2 (i586 x86_64):

gstreamer-plugins-bad-1.8.3-3.1
gstreamer-plugins-bad-debuginfo-1.8.3-3.1
gstreamer-plugins-bad-debugsource-1.8.3-3.1
gstreamer-plugins-bad-devel-1.8.3-3.1
gstreamer-plugins-bad-doc-1.8.3-3.1
libgstadaptivedemux-1_0-0-1.8.3-3.1
libgstadaptivedemux-1_0-0-debuginfo-1.8.3-3.1
libgstbadaudio-1_0-0-1.8.3-3.1
libgstbadaudio-1_0-0-debuginfo-1.8.3-3.1
libgstbadbase-1_0-0-1.8.3-3.1
libgstbadbase-1_0-0-debuginfo-1.8.3-3.1
libgstbadvideo-1_0-0-1.8.3-3.1
libgstbadvideo-1_0-0-debuginfo-1.8.3-3.1
libgstbasecamerabinsrc-1_0-0-1.8.3-3.1
libgstbasecamerabinsrc-1_0-0-debuginfo-1.8.3-3.1
libgstcodecparsers-1_0-0-1.8.3-3.1
libgstcodecparsers-1_0-0-debuginfo-1.8.3-3.1
libgstgl-1_0-0-1.8.3-3.1
libgstgl-1_0-0-debuginfo-1.8.3-3.1
libgstinsertbin-1_0-0-1.8.3-3.1
libgstinsertbin-1_0-0-debuginfo-1.8.3-3.1
libgstmpegts-1_0-0-1.8.3-3.1
libgstmpegts-1_0-0-debuginfo-1.8.3-3.1
libgstphotography-1_0-0-1.8.3-3.1
libgstphotography-1_0-0-debuginfo-1.8.3-3.1
libgstplayer-1_0-0-1.8.3-3.1
libgstplayer-1_0-0-debuginfo-1.8.3-3.1
libgsturidownloader-1_0-0-1.8.3-3.1
libgsturidownloader-1_0-0-debuginfo-1.8.3-3.1
libgstvdpau-1.8.3-3.1
libgstvdpau-debuginfo-1.8.3-3.1
libgstwayland-1_0-0-1.8.3-3.1
libgstwayland-1_0-0-debuginfo-1.8.3-3.1

- openSUSE Leap 42.2 (x86_64):

gstreamer-plugins-bad-32bit-1.8.3-3.1
gstreamer-plugins-bad-debuginfo-32bit-1.8.3-3.1
libgstadaptivedemux-1_0-0-32bit-1.8.3-3.1
libgstadaptivedemux-1_0-0-debuginfo-32bit-1.8.3-3.1
libgstbadaudio-1_0-0-32bit-1.8.3-3.1
libgstbadaudio-1_0-0-debuginfo-32bit-1.8.3-3.1
libgstbadbase-1_0-0-32bit-1.8.3-3.1
libgstbadbase-1_0-0-debuginfo-32bit-1.8.3-3.1
libgstbadvideo-1_0-0-32bit-1.8.3-3.1
libgstbadvideo-1_0-0-debuginfo-32bit-1.8.3-3.1
libgstbasecamerabinsrc-1_0-0-32bit-1.8.3-3.1
libgstbasecamerabinsrc-1_0-0-debuginfo-32bit-1.8.3-3.1
libgstcodecparsers-1_0-0-32bit-1.8.3-3.1
libgstcodecparsers-1_0-0-debuginfo-32bit-1.8.3-3.1
libgstgl-1_0-0-32bit-1.8.3-3.1
libgstgl-1_0-0-debuginfo-32bit-1.8.3-3.1
libgstinsertbin-1_0-0-32bit-1.8.3-3.1
libgstinsertbin-1_0-0-debuginfo-32bit-1.8.3-3.1
libgstmpegts-1_0-0-32bit-1.8.3-3.1
libgstmpegts-1_0-0-debuginfo-32bit-1.8.3-3.1
libgstphotography-1_0-0-32bit-1.8.3-3.1
libgstphotography-1_0-0-debuginfo-32bit-1.8.3-3.1
libgstplayer-1_0-0-32bit-1.8.3-3.1
libgstplayer-1_0-0-debuginfo-32bit-1.8.3-3.1
libgsturidownloader-1_0-0-32bit-1.8.3-3.1
libgsturidownloader-1_0-0-debuginfo-32bit-1.8.3-3.1
libgstvdpau-32bit-1.8.3-3.1
libgstvdpau-debuginfo-32bit-1.8.3-3.1
libgstwayland-1_0-0-32bit-1.8.3-3.1
libgstwayland-1_0-0-debuginfo-32bit-1.8.3-3.1

- openSUSE Leap 42.2 (noarch):

gstreamer-plugins-bad-lang-1.8.3-3.1


References:

https://www.suse.com/security/cve/CVE-2016-9445.html
https://www.suse.com/security/cve/CVE-2016-9446.html
https://www.suse.com/security/cve/CVE-2016-9809.html
https://www.suse.com/security/cve/CVE-2016-9812.html
https://www.suse.com/security/cve/CVE-2016-9813.html
https://bugzilla.suse.com/1010829
https://bugzilla.suse.com/1013659
https://bugzilla.suse.com/1013678
https://bugzilla.suse.com/1013680


< Previous Next >
This Thread
  • No further messages