Mailinglist Archive: opensuse-updates (127 mails)

< Previous Next >
openSUSE-SU-2016:1526-1: moderate: Security update for libimobiledevice, libusbmuxd
openSUSE Security Update: Security update for libimobiledevice, libusbmuxd
______________________________________________________________________________

Announcement ID: openSUSE-SU-2016:1526-1
Rating: moderate
References: #982014
Cross-References: CVE-2016-5104
Affected Products:
openSUSE Leap 42.1
openSUSE 13.2
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:


This update for libimobiledevice, libusbmuxd fixes the following issues:

- Add libimobiledevice-CVE-2016-5104.patch: Make sure sockets only listen
locally (CVE-2016-5104, boo#982014).


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.1:

zypper in -t patch openSUSE-2016-698=1

- openSUSE 13.2:

zypper in -t patch openSUSE-2016-698=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.1 (i586 x86_64):

imobiledevice-tools-1.2.0-6.2
imobiledevice-tools-debuginfo-1.2.0-6.2
iproxy-1.0.10-4.1
iproxy-debuginfo-1.0.10-4.1
libimobiledevice-debugsource-1.2.0-6.2
libimobiledevice-devel-1.2.0-6.2
libimobiledevice-doc-1.2.0-6.2
libimobiledevice6-1.2.0-6.2
libimobiledevice6-debuginfo-1.2.0-6.2
libusbmuxd-debugsource-1.0.10-4.1
libusbmuxd-devel-1.0.10-4.1
libusbmuxd4-1.0.10-4.1
libusbmuxd4-debuginfo-1.0.10-4.1
python-imobiledevice-1.2.0-6.2
python-imobiledevice-debuginfo-1.2.0-6.2

- openSUSE Leap 42.1 (x86_64):

libimobiledevice6-32bit-1.2.0-6.2
libimobiledevice6-debuginfo-32bit-1.2.0-6.2
libusbmuxd4-32bit-1.0.10-4.1
libusbmuxd4-debuginfo-32bit-1.0.10-4.1

- openSUSE 13.2 (i586 x86_64):

imobiledevice-tools-1.1.6-2.3.1
imobiledevice-tools-debuginfo-1.1.6-2.3.1
iproxy-1.0.9-2.3.1
iproxy-debuginfo-1.0.9-2.3.1
libimobiledevice-debugsource-1.1.6-2.3.1
libimobiledevice-devel-1.1.6-2.3.1
libimobiledevice-doc-1.1.6-2.3.1
libimobiledevice4-1.1.6-2.3.1
libimobiledevice4-debuginfo-1.1.6-2.3.1
libusbmuxd-debugsource-1.0.9-2.3.1
libusbmuxd-devel-1.0.9-2.3.1
libusbmuxd2-1.0.9-2.3.1
libusbmuxd2-debuginfo-1.0.9-2.3.1
python-imobiledevice-1.1.6-2.3.1
python-imobiledevice-debuginfo-1.1.6-2.3.1

- openSUSE 13.2 (x86_64):

libimobiledevice4-32bit-1.1.6-2.3.1
libimobiledevice4-debuginfo-32bit-1.1.6-2.3.1
libusbmuxd2-32bit-1.0.9-2.3.1
libusbmuxd2-debuginfo-32bit-1.0.9-2.3.1


References:

https://www.suse.com/security/cve/CVE-2016-5104.html
https://bugzilla.suse.com/982014


< Previous Next >
This Thread
  • No further messages