Mailinglist Archive: opensuse-updates (170 mails)

< Previous Next >
openSUSE-SU-2016:0486-1: moderate: Security update for libnettle
openSUSE Security Update: Security update for libnettle
______________________________________________________________________________

Announcement ID: openSUSE-SU-2016:0486-1
Rating: moderate
References: #964845 #964847 #964849
Cross-References: CVE-2015-8803 CVE-2015-8804 CVE-2015-8805

Affected Products:
openSUSE 13.1
______________________________________________________________________________

An update that fixes three vulnerabilities is now available.

Description:


This update for libnettle fixes the following issues:

- CVE-2015-8803: secp256 calculation bug (boo#964845)
- CVE-2015-8804: Miscalculations on secp384 curve (boo#964847)
- CVE-2015-8805: Fixed miscomputation bugs in secp-256r1 modulo functions.
(boo#964849)


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 13.1:

zypper in -t patch 2016-217=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 13.1 (i586 x86_64):

libhogweed2-2.7.1-2.3.1
libhogweed2-debuginfo-2.7.1-2.3.1
libnettle-debugsource-2.7.1-2.3.1
libnettle-devel-2.7.1-2.3.1
libnettle4-2.7.1-2.3.1
libnettle4-debuginfo-2.7.1-2.3.1
nettle-2.7.1-2.3.1
nettle-debuginfo-2.7.1-2.3.1

- openSUSE 13.1 (x86_64):

libhogweed2-32bit-2.7.1-2.3.1
libhogweed2-debuginfo-32bit-2.7.1-2.3.1
libnettle-devel-32bit-2.7.1-2.3.1
libnettle4-32bit-2.7.1-2.3.1
libnettle4-debuginfo-32bit-2.7.1-2.3.1


References:

https://www.suse.com/security/cve/CVE-2015-8803.html
https://www.suse.com/security/cve/CVE-2015-8804.html
https://www.suse.com/security/cve/CVE-2015-8805.html
https://bugzilla.suse.com/964845
https://bugzilla.suse.com/964847
https://bugzilla.suse.com/964849


< Previous Next >
This Thread
  • No further messages