Mailinglist Archive: opensuse-updates (174 mails)

< Previous Next >
openSUSE-SU-2015:2136-1: moderate: Security update for libpng12
openSUSE Security Update: Security update for libpng12
______________________________________________________________________________

Announcement ID: openSUSE-SU-2015:2136-1
Rating: moderate
References: #952051 #954980
Cross-References: CVE-2015-7981 CVE-2015-8126
Affected Products:
openSUSE Leap 42.1
______________________________________________________________________________

An update that fixes two vulnerabilities is now available.

Description:

The libpng12 package was updated to fix the following security issues:

- CVE-2015-8126: Fixed a buffer overflow vulnerabilities in
png_get_PLTE/png_set_PLTE functions (bsc#954980).
- CVE-2015-7981: Fixed an out-of-bound read (bsc#952051).


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.1:

zypper in -t patch openSUSE-2015-826=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.1 (i586 x86_64):

libpng12-0-1.2.50-5.1
libpng12-0-debuginfo-1.2.50-5.1
libpng12-compat-devel-1.2.50-5.1
libpng12-debugsource-1.2.50-5.1
libpng12-devel-1.2.50-5.1

- openSUSE Leap 42.1 (x86_64):

libpng12-0-32bit-1.2.50-5.1
libpng12-0-debuginfo-32bit-1.2.50-5.1
libpng12-compat-devel-32bit-1.2.50-5.1
libpng12-devel-32bit-1.2.50-5.1


References:

https://www.suse.com/security/cve/CVE-2015-7981.html
https://www.suse.com/security/cve/CVE-2015-8126.html
https://bugzilla.suse.com/952051
https://bugzilla.suse.com/954980


< Previous Next >
This Thread
  • No further messages