Mailinglist Archive: opensuse-updates (174 mails)

< Previous Next >
openSUSE-SU-2015:2130-1: moderate: cyrus-imapd
openSUSE Security Update: cyrus-imapd
______________________________________________________________________________

Announcement ID: openSUSE-SU-2015:2130-1
Rating: moderate
References: #954200 #954201
Cross-References: CVE-2015-8077 CVE-2015-8078
Affected Products:
openSUSE Leap 42.1
openSUSE 13.2
______________________________________________________________________________

An update that fixes two vulnerabilities is now available.

Description:

The cyrus-imapd package was updated to fix two security issues.

- CVE-2015-8077: Integer overflow in range checks (bnc#954200)
- CVE-2015-8078: Integer overflow in index_urlfetch (bnc#954201)


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.1:

zypper in -t patch openSUSE-2015-828=1

- openSUSE 13.2:

zypper in -t patch openSUSE-2015-828=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.1 (i586 x86_64):

cyradm-2.4.18-3.1
cyrus-imapd-2.4.18-3.1
cyrus-imapd-debuginfo-2.4.18-3.1
cyrus-imapd-debugsource-2.4.18-3.1
cyrus-imapd-devel-2.4.18-3.1
cyrus-imapd-snmp-2.4.18-3.1
cyrus-imapd-snmp-mibs-2.4.18-3.1
cyrus-imapd-utils-2.4.18-3.1
perl-Cyrus-IMAP-2.4.18-3.1
perl-Cyrus-IMAP-debuginfo-2.4.18-3.1
perl-Cyrus-SIEVE-managesieve-2.4.18-3.1
perl-Cyrus-SIEVE-managesieve-debuginfo-2.4.18-3.1

- openSUSE 13.2 (i586 x86_64):

cyradm-2.4.18-2.10.1
cyrus-imapd-2.4.18-2.10.1
cyrus-imapd-debuginfo-2.4.18-2.10.1
cyrus-imapd-debugsource-2.4.18-2.10.1
cyrus-imapd-devel-2.4.18-2.10.1
cyrus-imapd-snmp-2.4.18-2.10.1
cyrus-imapd-snmp-mibs-2.4.18-2.10.1
cyrus-imapd-utils-2.4.18-2.10.1
perl-Cyrus-IMAP-2.4.18-2.10.1
perl-Cyrus-IMAP-debuginfo-2.4.18-2.10.1
perl-Cyrus-SIEVE-managesieve-2.4.18-2.10.1
perl-Cyrus-SIEVE-managesieve-debuginfo-2.4.18-2.10.1


References:

https://www.suse.com/security/cve/CVE-2015-8077.html
https://www.suse.com/security/cve/CVE-2015-8078.html
https://bugzilla.suse.com/954200
https://bugzilla.suse.com/954201


< Previous Next >
This Thread
  • No further messages