Mailinglist Archive: opensuse-updates (174 mails)

< Previous Next >
openSUSE-SU-2015:2023-1: moderate: Security update for putty
openSUSE Security Update: Security update for putty
______________________________________________________________________________

Announcement ID: openSUSE-SU-2015:2023-1
Rating: moderate
References: #954191
Cross-References: CVE-2015-5309
Affected Products:
openSUSE Leap 42.1
openSUSE 13.2
openSUSE 13.1
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

PuTTY was updated to 0.66 to fix security issues and bugs.

The following vulnerabilities were fixed:

* CVE-2015-5309: Malicious ECH control sequences could have caused an
integer overflow, buffer underrun in terminal emulator bnc#954191

Also contains all bug fixes up to the 0.66 release.


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.1:

zypper in -t patch openSUSE-2015-766=1

- openSUSE 13.2:

zypper in -t patch openSUSE-2015-766=1

- openSUSE 13.1:

zypper in -t patch openSUSE-2015-766=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.1 (i586 x86_64):

putty-0.66-6.1
putty-debuginfo-0.66-6.1
putty-debugsource-0.66-6.1

- openSUSE 13.2 (i586 x86_64):

putty-0.66-4.7.1
putty-debuginfo-0.66-4.7.1
putty-debugsource-0.66-4.7.1

- openSUSE 13.1 (i586 x86_64):

putty-0.66-2.7.1
putty-debuginfo-0.66-2.7.1
putty-debugsource-0.66-2.7.1


References:

https://www.suse.com/security/cve/CVE-2015-5309.html
https://bugzilla.suse.com/954191


< Previous Next >
This Thread
  • No further messages