Mailinglist Archive: opensuse-updates (174 mails)

< Previous Next >
openSUSE-SU-2015:1910-1: moderate: Security update for util-linux
openSUSE Security Update: Security update for util-linux
______________________________________________________________________________

Announcement ID: openSUSE-SU-2015:1910-1
Rating: moderate
References: #903440 #949754
Cross-References: CVE-2015-5218
Affected Products:
openSUSE Leap 42.1
openSUSE 13.2
openSUSE 13.1
______________________________________________________________________________

An update that solves one vulnerability and has one errata
is now available.

Description:

util-linux was updated to fix one security issue.

This security issue was fixed:
- CVE-2015-5218: Prevent colcrt buffer overflow (bsc#949754).

This non-security issue was fixed:
- bsc#903440: Calendar "cal" crash with segmentation fault when execute
in background.


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.1:

zypper in -t patch openSUSE-2015-702=1

- openSUSE 13.2:

zypper in -t patch openSUSE-2015-702=1

- openSUSE 13.1:

zypper in -t patch openSUSE-2015-702=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.1 (i586 x86_64):

libblkid-devel-2.25-9.4
libblkid1-2.25-9.4
libblkid1-debuginfo-2.25-9.4
libmount-devel-2.25-9.4
libmount1-2.25-9.4
libmount1-debuginfo-2.25-9.4
libsmartcols-devel-2.25-9.4
libsmartcols1-2.25-9.4
libsmartcols1-debuginfo-2.25-9.4
libuuid-devel-2.25-9.4
libuuid1-2.25-9.4
libuuid1-debuginfo-2.25-9.4
python-libmount-2.25-9.5
python-libmount-debuginfo-2.25-9.5
python-libmount-debugsource-2.25-9.5
util-linux-2.25-9.4
util-linux-debuginfo-2.25-9.4
util-linux-debugsource-2.25-9.4
util-linux-systemd-2.25-9.1
util-linux-systemd-debuginfo-2.25-9.1
util-linux-systemd-debugsource-2.25-9.1
uuidd-2.25-9.1
uuidd-debuginfo-2.25-9.1

- openSUSE Leap 42.1 (x86_64):

libblkid-devel-32bit-2.25-9.4
libblkid1-32bit-2.25-9.4
libblkid1-debuginfo-32bit-2.25-9.4
libmount-devel-32bit-2.25-9.4
libmount1-32bit-2.25-9.4
libmount1-debuginfo-32bit-2.25-9.4
libuuid-devel-32bit-2.25-9.4
libuuid1-32bit-2.25-9.4
libuuid1-debuginfo-32bit-2.25-9.4

- openSUSE Leap 42.1 (noarch):

util-linux-lang-2.25-9.4

- openSUSE 13.2 (i586 x86_64):

libblkid-devel-2.25.1-20.1
libblkid-devel-static-2.25.1-20.1
libblkid1-2.25.1-20.1
libblkid1-debuginfo-2.25.1-20.1
libmount-devel-2.25.1-20.1
libmount-devel-static-2.25.1-20.1
libmount1-2.25.1-20.1
libmount1-debuginfo-2.25.1-20.1
libsmartcols-devel-2.25.1-20.1
libsmartcols-devel-static-2.25.1-20.1
libsmartcols1-2.25.1-20.1
libsmartcols1-debuginfo-2.25.1-20.1
libuuid-devel-2.25.1-20.1
libuuid-devel-static-2.25.1-20.1
libuuid1-2.25.1-20.1
libuuid1-debuginfo-2.25.1-20.1
python-libmount-2.25.1-20.2
python-libmount-debuginfo-2.25.1-20.2
python-libmount-debugsource-2.25.1-20.2
util-linux-2.25.1-20.1
util-linux-debuginfo-2.25.1-20.1
util-linux-debugsource-2.25.1-20.1
util-linux-systemd-2.25.1-20.1
util-linux-systemd-debuginfo-2.25.1-20.1
util-linux-systemd-debugsource-2.25.1-20.1
uuidd-2.25.1-20.1
uuidd-debuginfo-2.25.1-20.1

- openSUSE 13.2 (x86_64):

libblkid-devel-32bit-2.25.1-20.1
libblkid1-32bit-2.25.1-20.1
libblkid1-debuginfo-32bit-2.25.1-20.1
libmount-devel-32bit-2.25.1-20.1
libmount1-32bit-2.25.1-20.1
libmount1-debuginfo-32bit-2.25.1-20.1
libuuid-devel-32bit-2.25.1-20.1
libuuid1-32bit-2.25.1-20.1
libuuid1-debuginfo-32bit-2.25.1-20.1

- openSUSE 13.2 (noarch):

util-linux-lang-2.25.1-20.1

- openSUSE 13.1 (i586 x86_64):

libblkid-devel-2.23.2-34.1
libblkid1-2.23.2-34.1
libblkid1-debuginfo-2.23.2-34.1
libmount-devel-2.23.2-34.1
libmount1-2.23.2-34.1
libmount1-debuginfo-2.23.2-34.1
libuuid-devel-2.23.2-34.1
libuuid1-2.23.2-34.1
libuuid1-debuginfo-2.23.2-34.1
util-linux-2.23.2-34.1
util-linux-debuginfo-2.23.2-34.1
util-linux-debugsource-2.23.2-34.1
uuidd-2.23.2-34.1
uuidd-debuginfo-2.23.2-34.1

- openSUSE 13.1 (x86_64):

libblkid-devel-32bit-2.23.2-34.1
libblkid1-32bit-2.23.2-34.1
libblkid1-debuginfo-32bit-2.23.2-34.1
libmount-devel-32bit-2.23.2-34.1
libmount1-32bit-2.23.2-34.1
libmount1-debuginfo-32bit-2.23.2-34.1
libuuid-devel-32bit-2.23.2-34.1
libuuid1-32bit-2.23.2-34.1
libuuid1-debuginfo-32bit-2.23.2-34.1

- openSUSE 13.1 (noarch):

util-linux-lang-2.23.2-34.1


References:

https://www.suse.com/security/cve/CVE-2015-5218.html
https://bugzilla.suse.com/903440
https://bugzilla.suse.com/949754


< Previous Next >
This Thread
  • No further messages