Mailinglist Archive: opensuse-updates (61 mails)

< Previous Next >
openSUSE-SU-2015:0798-1: moderate: Security update for python-Pillow
openSUSE Security Update: Security update for python-Pillow
______________________________________________________________________________

Announcement ID: openSUSE-SU-2015:0798-1
Rating: moderate
References: #921566
Cross-References: CVE-2014-3589 CVE-2014-3598 CVE-2014-9601

Affected Products:
openSUSE 13.2
______________________________________________________________________________

An update that fixes three vulnerabilities is now available.

Description:

python-pillow was updated to 2.7.0 to fix security issues and bugs.

The following vulnerabilities were fixed:

* CVE-2014-9601: Remote attackers could cause a denial of service via a
compressed text chunk in a PNG image that has a large size when it is
decompressed.
* CVE-2014-3598: Remote attackers could cause a denial of service using
specially crafted image files via Jpeg2KImagePlugin
* CVE-2014-3589: Remote attackers could cause a denial of service using
specially crafted image files via IcnsImagePlugin


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 13.2:

zypper in -t patch openSUSE-2015-337=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 13.2 (i586 x86_64):

python-Pillow-2.8.1-3.3.1
python-Pillow-debuginfo-2.8.1-3.3.1
python-Pillow-debugsource-2.8.1-3.3.1
python-Pillow-tk-2.8.1-3.3.1
python-Pillow-tk-debuginfo-2.8.1-3.3.1


References:

https://www.suse.com/security/cve/CVE-2014-3589.html
https://www.suse.com/security/cve/CVE-2014-3598.html
https://www.suse.com/security/cve/CVE-2014-9601.html
https://bugzilla.suse.com/921566


< Previous Next >
This Thread
  • No further messages