Mailinglist Archive: opensuse-updates (89 mails)

< Previous Next >
openSUSE-SU-2015:0041-1: moderate: Security update for libsndfile
openSUSE Security Update: Security update for libsndfile
______________________________________________________________________________

Announcement ID: openSUSE-SU-2015:0041-1
Rating: moderate
References: #911796
Cross-References: CVE-2014-9496
Affected Products:
openSUSE 13.2
openSUSE 13.1
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

Changes in libsndfile: two buffer read overflows in sd2_parse_rsrc_fork()
(CVE-2014-9496, bnc#911796): backported upstream fix patches


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 13.2:

zypper in -t patch openSUSE-2015-18

- openSUSE 13.1:

zypper in -t patch openSUSE-2015-18

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 13.2 (i586 x86_64):

libsndfile-debugsource-1.0.25-19.4.1
libsndfile-devel-1.0.25-19.4.1
libsndfile-progs-1.0.25-19.4.1
libsndfile-progs-debuginfo-1.0.25-19.4.1
libsndfile-progs-debugsource-1.0.25-19.4.1
libsndfile1-1.0.25-19.4.1
libsndfile1-debuginfo-1.0.25-19.4.1

- openSUSE 13.2 (x86_64):

libsndfile1-32bit-1.0.25-19.4.1
libsndfile1-debuginfo-32bit-1.0.25-19.4.1

- openSUSE 13.1 (i586 x86_64):

libsndfile-debugsource-1.0.25-17.4.1
libsndfile-devel-1.0.25-17.4.1
libsndfile-progs-1.0.25-17.4.1
libsndfile-progs-debuginfo-1.0.25-17.4.1
libsndfile-progs-debugsource-1.0.25-17.4.1
libsndfile1-1.0.25-17.4.1
libsndfile1-debuginfo-1.0.25-17.4.1

- openSUSE 13.1 (x86_64):

libsndfile1-32bit-1.0.25-17.4.1
libsndfile1-debuginfo-32bit-1.0.25-17.4.1


References:

http://support.novell.com/security/cve/CVE-2014-9496.html
https://bugzilla.suse.com/show_bug.cgi?id=911796


< Previous Next >
This Thread
  • No further messages