Mailinglist Archive: opensuse-updates (114 mails)

< Previous Next >
openSUSE-SU-2014:1503-1: moderate: update for wireshark
openSUSE Security Update: update for wireshark
______________________________________________________________________________

Announcement ID: openSUSE-SU-2014:1503-1
Rating: moderate
References: #905245 #905246 #905247 #905248
Cross-References: CVE-2014-8710 CVE-2014-8711 CVE-2014-8712
CVE-2014-8713 CVE-2014-8714
Affected Products:
openSUSE 13.2
openSUSE 13.1
openSUSE 12.3
______________________________________________________________________________

An update that fixes 5 vulnerabilities is now available.

Description:

wireshark was updated to fix five security issues.

These security issues were fixed:
- SigComp UDVM buffer overflow (CVE-2014-8710).
- AMQP crash (CVE-2014-8711).
- NCP crashes (CVE-2014-8712, CVE-2014-8713).
- TN5250 infinite loops (CVE-2014-8714).

For openSUSE 12.3 and 13.1 further bug fixes and updated protocol support
are described in:
https://www.wireshark.org/docs/relnotes/wireshark-1.10.11.html

For openSUSE 13.2 further bug fixes and updated protocol support are
described in: https://www.wireshark.org/docs/relnotes/wireshark-1.12.2.html


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 13.2:

zypper in -t patch openSUSE-2014-717

- openSUSE 13.1:

zypper in -t patch openSUSE-2014-717

- openSUSE 12.3:

zypper in -t patch openSUSE-2014-717

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 13.2 (i586 x86_64):

wireshark-1.12.2-4.1
wireshark-debuginfo-1.12.2-4.1
wireshark-debugsource-1.12.2-4.1
wireshark-devel-1.12.2-4.1
wireshark-ui-gtk-1.12.2-4.1
wireshark-ui-gtk-debuginfo-1.12.2-4.1
wireshark-ui-qt-1.12.2-4.1
wireshark-ui-qt-debuginfo-1.12.2-4.1

- openSUSE 13.1 (i586 x86_64):

wireshark-1.10.11-28.1
wireshark-debuginfo-1.10.11-28.1
wireshark-debugsource-1.10.11-28.1
wireshark-devel-1.10.11-28.1

- openSUSE 12.3 (i586 x86_64):

wireshark-1.10.11-1.48.1
wireshark-debuginfo-1.10.11-1.48.1
wireshark-debugsource-1.10.11-1.48.1
wireshark-devel-1.10.11-1.48.1


References:

http://support.novell.com/security/cve/CVE-2014-8710.html
http://support.novell.com/security/cve/CVE-2014-8711.html
http://support.novell.com/security/cve/CVE-2014-8712.html
http://support.novell.com/security/cve/CVE-2014-8713.html
http://support.novell.com/security/cve/CVE-2014-8714.html
https://bugzilla.suse.com/show_bug.cgi?id=905245
https://bugzilla.suse.com/show_bug.cgi?id=905246
https://bugzilla.suse.com/show_bug.cgi?id=905247
https://bugzilla.suse.com/show_bug.cgi?id=905248


< Previous Next >
This Thread
  • No further messages