Mailinglist Archive: opensuse-updates (86 mails)

< Previous Next >
openSUSE-SU-2014:0650-1: moderate: libvirt: Fixed unsafe parsing of XML documents
openSUSE Security Update: libvirt: Fixed unsafe parsing of XML documents
______________________________________________________________________________

Announcement ID: openSUSE-SU-2014:0650-1
Rating: moderate
References: #873705
Cross-References: CVE-2014-0179
Affected Products:
openSUSE 12.3
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

libvirt was patched to prevent expansion of entities when parsing XML
files. This vulnerability allowed malicious users to read arbitrary files
or cause a denial of service (CVE-2014-0179).


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 12.3:

zypper in -t patch openSUSE-2014-369

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 12.3 (i586 x86_64):

libvirt-1.0.2-1.18.1
libvirt-client-1.0.2-1.18.1
libvirt-client-debuginfo-1.0.2-1.18.1
libvirt-debuginfo-1.0.2-1.18.1
libvirt-debugsource-1.0.2-1.18.1
libvirt-devel-1.0.2-1.18.1
libvirt-doc-1.0.2-1.18.1
libvirt-lock-sanlock-1.0.2-1.18.1
libvirt-lock-sanlock-debuginfo-1.0.2-1.18.1
libvirt-python-1.0.2-1.18.1
libvirt-python-debuginfo-1.0.2-1.18.1

- openSUSE 12.3 (x86_64):

libvirt-client-32bit-1.0.2-1.18.1
libvirt-client-debuginfo-32bit-1.0.2-1.18.1
libvirt-devel-32bit-1.0.2-1.18.1


References:

http://support.novell.com/security/cve/CVE-2014-0179.html
https://bugzilla.novell.com/873705


< Previous Next >
This Thread
  • No further messages