Mailinglist Archive: opensuse-updates (102 mails)

< Previous Next >
openSUSE-SU-2014:0332-1: moderate: rubygems: fix applying rubygem patches correctly to the tree
openSUSE Security Update: rubygems: fix applying rubygem patches correctly
to the tree
______________________________________________________________________________

Announcement ID: openSUSE-SU-2014:0332-1
Rating: moderate
References: #864873
Affected Products:
openSUSE 13.1
openSUSE 12.3
______________________________________________________________________________

An update that contains security fixes can now be installed.

Description:


This update fixes the following issue with some rubygems:
- bnc#864873: fix rubygem patches are not applied to the
gem but only to the tree. Packages embedding rubygems via
their .gem files were not receiving security updates.


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 13.1:

zypper in -t patch openSUSE-2014-185

- openSUSE 12.3:

zypper in -t patch openSUSE-2014-185

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 13.1 (i586 x86_64):

rubygem-actionmailer-3_2-3.2.13-2.10.1
rubygem-actionmailer-3_2-doc-3.2.13-2.10.1
rubygem-actionpack-3_2-3.2.13-2.13.1
rubygem-actionpack-3_2-doc-3.2.13-2.13.1
rubygem-activesupport-3_2-3.2.13-3.10.1
rubygem-activesupport-3_2-doc-3.2.13-3.10.1

- openSUSE 12.3 (i586 x86_64):

rubygem-actionmailer-3_2-3.2.12-1.10.1
rubygem-actionmailer-3_2-doc-3.2.12-1.10.1
rubygem-actionpack-3_2-3.2.12-1.17.1
rubygem-actionpack-3_2-doc-3.2.12-1.17.1
rubygem-activerecord-3_2-3.2.12-1.10.1
rubygem-activerecord-3_2-doc-3.2.12-1.10.1
rubygem-activesupport-3_2-3.2.12-1.10.1
rubygem-activesupport-3_2-doc-3.2.12-1.10.1


References:

https://bugzilla.novell.com/864873


< Previous Next >
This Thread
  • No further messages