Mailinglist Archive: opensuse-updates (108 mails)

< Previous Next >
openSUSE-SU-2014:0127-1: moderate: update for hplip
openSUSE Security Update: update for hplip
______________________________________________________________________________

Announcement ID: openSUSE-SU-2014:0127-1
Rating: moderate
References: #852368 #853405
Cross-References: CVE-2013-6402 CVE-2013-6427
Affected Products:
openSUSE 13.1
openSUSE 12.3
openSUSE 12.2
______________________________________________________________________________

An update that fixes two vulnerabilities is now available.

Description:


- fix-CVE-2013-6402.dif fixes hardcoded file name
/tmp/hp-pkservice.log in pkit.py (bnc#852368).
- disable_hp-upgrade.patch disables hp-upgrade/upgrade.py
for security reasons (bnc#853405). To upgrade HPLIP an
openSUSE software package manager like YaST or zypper
should be used. (CVE-2013-6427)


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 13.1:

zypper in -t patch openSUSE-2014-80

- openSUSE 12.3:

zypper in -t patch openSUSE-2014-80

- openSUSE 12.2:

zypper in -t patch openSUSE-2014-80

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 13.1 (i586 x86_64):

hplip-3.13.10-4.2
hplip-debuginfo-3.13.10-4.2
hplip-debugsource-3.13.10-4.2
hplip-hpijs-3.13.10-4.2
hplip-hpijs-debuginfo-3.13.10-4.2
hplip-sane-3.13.10-4.2
hplip-sane-debuginfo-3.13.10-4.2

- openSUSE 12.3 (i586 x86_64):

hplip-3.12.11-2.9.2
hplip-debuginfo-3.12.11-2.9.2
hplip-debugsource-3.12.11-2.9.2
hplip-hpijs-3.12.11-2.9.2
hplip-hpijs-debuginfo-3.12.11-2.9.2
hplip-sane-3.12.11-2.9.2
hplip-sane-debuginfo-3.12.11-2.9.2

- openSUSE 12.2 (i586 x86_64):

hplip-3.12.4-3.10.1
hplip-debuginfo-3.12.4-3.10.1
hplip-debugsource-3.12.4-3.10.1
hplip-hpijs-3.12.4-3.10.1
hplip-hpijs-debuginfo-3.12.4-3.10.1
hplip-sane-3.12.4-3.10.1
hplip-sane-debuginfo-3.12.4-3.10.1


References:

http://support.novell.com/security/cve/CVE-2013-6402.html
http://support.novell.com/security/cve/CVE-2013-6427.html
https://bugzilla.novell.com/852368
https://bugzilla.novell.com/853405


< Previous Next >
This Thread
  • No further messages