Mailinglist Archive: opensuse-updates (108 mails)

< Previous Next >
openSUSE-SU-2014:0070-1: moderate: update for libqt4
openSUSE Security Update: update for libqt4
______________________________________________________________________________

Announcement ID: openSUSE-SU-2014:0070-1
Rating: moderate
References: #856832
Cross-References: CVE-2013-4549
Affected Products:
openSUSE 12.2
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:


- Fixes XML Entity Expansion Denial of Service (bnc#856832,
CVE-2013-4549)
* add backported patch
libqt4-disallow-deep-or-widely-nested-entity-references.patc
h
* add backported patch
libqt4-fully-expand-all-entities.patch


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 12.2:

zypper in -t patch openSUSE-2014-44

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 12.2 (i586 x86_64):

libqt4-4.8.1-2.20.1
libqt4-debuginfo-4.8.1-2.20.1
libqt4-debugsource-4.8.1-2.20.1
libqt4-devel-4.8.1-2.20.1
libqt4-devel-debuginfo-4.8.1-2.20.1
libqt4-devel-doc-4.8.1-2.20.2
libqt4-devel-doc-debuginfo-4.8.1-2.20.2
libqt4-devel-doc-debugsource-4.8.1-2.20.2
libqt4-private-headers-devel-4.8.1-2.20.1
libqt4-qt3support-4.8.1-2.20.1
libqt4-qt3support-debuginfo-4.8.1-2.20.1
libqt4-sql-4.8.1-2.20.1
libqt4-sql-debuginfo-4.8.1-2.20.1
libqt4-sql-mysql-4.8.1-2.20.1
libqt4-sql-mysql-debuginfo-4.8.1-2.20.1
libqt4-sql-plugins-debugsource-4.8.1-2.20.1
libqt4-sql-postgresql-4.8.1-2.20.1
libqt4-sql-postgresql-debuginfo-4.8.1-2.20.1
libqt4-sql-sqlite-4.8.1-2.20.1
libqt4-sql-sqlite-debuginfo-4.8.1-2.20.1
libqt4-sql-unixODBC-4.8.1-2.20.1
libqt4-sql-unixODBC-debuginfo-4.8.1-2.20.1
libqt4-x11-4.8.1-2.20.1
libqt4-x11-debuginfo-4.8.1-2.20.1
qt4-x11-tools-4.8.1-2.20.2
qt4-x11-tools-debuginfo-4.8.1-2.20.2

- openSUSE 12.2 (x86_64):

libqt4-32bit-4.8.1-2.20.1
libqt4-debuginfo-32bit-4.8.1-2.20.1
libqt4-qt3support-32bit-4.8.1-2.20.1
libqt4-qt3support-debuginfo-32bit-4.8.1-2.20.1
libqt4-sql-32bit-4.8.1-2.20.1
libqt4-sql-debuginfo-32bit-4.8.1-2.20.1
libqt4-sql-mysql-32bit-4.8.1-2.20.1
libqt4-sql-mysql-debuginfo-32bit-4.8.1-2.20.1
libqt4-sql-postgresql-32bit-4.8.1-2.20.1
libqt4-sql-postgresql-debuginfo-32bit-4.8.1-2.20.1
libqt4-sql-sqlite-32bit-4.8.1-2.20.1
libqt4-sql-sqlite-debuginfo-32bit-4.8.1-2.20.1
libqt4-sql-unixODBC-32bit-4.8.1-2.20.1
libqt4-sql-unixODBC-debuginfo-32bit-4.8.1-2.20.1
libqt4-x11-32bit-4.8.1-2.20.1
libqt4-x11-debuginfo-32bit-4.8.1-2.20.1

- openSUSE 12.2 (noarch):

libqt4-devel-doc-data-4.8.1-2.20.2


References:

http://support.novell.com/security/cve/CVE-2013-4549.html
https://bugzilla.novell.com/856832


< Previous Next >
This Thread
  • No further messages