Mailinglist Archive: opensuse-updates (101 mails)

< Previous Next >
openSUSE-SU-2014:0019-1: moderate: update for rubygem-actionpack-2_3
openSUSE Security Update: update for rubygem-actionpack-2_3

Announcement ID: openSUSE-SU-2014:0019-1
Rating: moderate
References: #809935 #809940 #853632
Cross-References: CVE-2013-1855 CVE-2013-1857 CVE-2013-6415

Affected Products:
openSUSE 11.4

An update that fixes three vulnerabilities is now available.


Update consists of 3 fixes:
-fix CVE-2013-6415: number_to_currency XSS (bnc#853632).
-fix CVE-2013-1855: rubygem-actionpack*: XSS vulnerability
insanitize_css in Action Pack (bnc#809935)
-fix CVE-2013-1857: rubygem-actionpack*: XSS Vulnerability
in the sanitize` helper of Ruby on Rails (bnc#809940)

Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 11.4:

zypper in -t patch 2014-3

To bring your system up-to-date, use "zypper patch".

Package List:

- openSUSE 11.4 (i586 x86_64):



< Previous Next >
This Thread
  • No further messages