Mailinglist Archive: opensuse-updates (130 mails)

< Previous Next >
openSUSE-SU-2013:1960-1: moderate: v8
openSUSE Security Update: v8
______________________________________________________________________________

Announcement ID: openSUSE-SU-2013:1960-1
Rating: moderate
References: #854473
Cross-References: CVE-2013-6638 CVE-2013-6639 CVE-2013-6640

Affected Products:
openSUSE 12.3
______________________________________________________________________________

An update that fixes three vulnerabilities is now available.

Description:


- Update spec-file to fit the changes in V8 (addition of
internal ICU)
* Building against system ICU
* Regenerate Makefiles before using them

- Update to 3.22.24.8
- Security fixes (bnc#854473):
* CVE-2013-6638: Buffer overflow in v8
* CVE-2013-6639: Out of bounds write in v8
* CVE-2013-6640: Out of bounds read in v8


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 12.3:

zypper in -t patch openSUSE-2013-1025

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 12.3 (i586 x86_64):

libv8-3-3.22.24.8-2.4.1
libv8-3-debuginfo-3.22.24.8-2.4.1
v8-devel-3.22.24.8-2.4.1
v8-private-headers-devel-3.22.24.8-2.4.1


References:

http://support.novell.com/security/cve/CVE-2013-6638.html
http://support.novell.com/security/cve/CVE-2013-6639.html
http://support.novell.com/security/cve/CVE-2013-6640.html
https://bugzilla.novell.com/854473


< Previous Next >
This Thread
  • No further messages