Mailinglist Archive: opensuse-updates (130 mails)

< Previous Next >
openSUSE-SU-2013:1834-1: moderate: update for ruby20
openSUSE Security Update: update for ruby20
______________________________________________________________________________

Announcement ID: openSUSE-SU-2013:1834-1
Rating: moderate
References: #851803
Cross-References: CVE-2013-4164
Affected Products:
openSUSE 13.1
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

the following security issue was fixed in ruby20:
- fix CVE-2013-4164: heap overflow in float point parsing
(bnc#851803) The file CVE-2013-4164.patch contains the
patch


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 13.1:

zypper in -t patch openSUSE-2013-943

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 13.1 (i586 x86_64):

ruby20-2.0.0.p247-3.7.1
ruby20-debuginfo-2.0.0.p247-3.7.1
ruby20-debugsource-2.0.0.p247-3.7.1
ruby20-devel-2.0.0.p247-3.7.1
ruby20-devel-extra-2.0.0.p247-3.7.1
ruby20-tk-2.0.0.p247-3.7.1
ruby20-tk-debuginfo-2.0.0.p247-3.7.1

- openSUSE 13.1 (noarch):

ruby20-doc-ri-2.0.0.p247-3.7.1


References:

http://support.novell.com/security/cve/CVE-2013-4164.html
https://bugzilla.novell.com/851803


< Previous Next >
This Thread
  • No further messages