Mailinglist Archive: opensuse-updates (120 mails)

< Previous Next >
openSUSE-SU-2013:1645-1: moderate: update for openvpn
openSUSE Security Update: update for openvpn
______________________________________________________________________________

Announcement ID: openSUSE-SU-2013:1645-1
Rating: moderate
References: #843509
Cross-References: CVE-2013-2061
Affected Products:
openSUSE 12.3
openSUSE 12.2
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

The following security issues were fixed:
- Applied upstream patch changing to use a constant time
memcmp when comparing HMACs in openvpn_decrypt to address
ciphertext injection in UDP mode (CVE-2013-2061,
bnc#843509).
[0006-openvpn-2.0.9-HMAC-memcmp-CVE-2013-2061_bnc843509.patc
h]

Changes in openvpn:
- Applied upstream patch changing to use a constant time
memcmp when comparing HMACs in openvpn_decrypt to address
ciphertext injection in UDP mode (CVE-2013-2061,
bnc#843509).
[0006-openvpn-2.0.9-HMAC-memcmp-CVE-2013-2061_bnc843509.patc
h]


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 12.3:

zypper in -t patch openSUSE-2013-823

- openSUSE 12.2:

zypper in -t patch openSUSE-2013-823

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 12.3 (i586 x86_64):

openvpn-2.2.2-9.5.1
openvpn-auth-pam-plugin-2.2.2-9.5.1
openvpn-auth-pam-plugin-debuginfo-2.2.2-9.5.1
openvpn-debuginfo-2.2.2-9.5.1
openvpn-debugsource-2.2.2-9.5.1
openvpn-down-root-plugin-2.2.2-9.5.1
openvpn-down-root-plugin-debuginfo-2.2.2-9.5.1

- openSUSE 12.2 (i586 x86_64):

openvpn-2.2.2-3.8.1
openvpn-auth-pam-plugin-2.2.2-3.8.1
openvpn-auth-pam-plugin-debuginfo-2.2.2-3.8.1
openvpn-debuginfo-2.2.2-3.8.1
openvpn-debugsource-2.2.2-3.8.1
openvpn-down-root-plugin-2.2.2-3.8.1
openvpn-down-root-plugin-debuginfo-2.2.2-3.8.1


References:

http://support.novell.com/security/cve/CVE-2013-2061.html
https://bugzilla.novell.com/843509


< Previous Next >
This Thread
  • No further messages