Mailinglist Archive: opensuse-updates (74 mails)

< Previous Next >
openSUSE-SU-2013:1443-1: moderate: squid
openSUSE Security Update: squid
______________________________________________________________________________

Announcement ID: openSUSE-SU-2013:1443-1
Rating: moderate
References: #677335 #796999 #829084
Cross-References: CVE-2012-5643 CVE-2013-0188 CVE-2013-0189
CVE-2013-4115
Affected Products:
openSUSE 11.4
______________________________________________________________________________

An update that fixes four vulnerabilities is now available.

Description:

This squid update includes several security fixes and minor
changes.

-
squid-2.7.x-bnc829084-CVE-2013-4115-BO_request_handling.diff
Squid advisory SQUID-2013_2, CVE-2013-4115, [bnc#829084]
Specially crafted http requests can trigger a buffer
overflow when squid attempts to resolve an overly long
hostname.
-
squid-2.7.x-bnc796999-bnc794954-CVE-2012-5643-CVE-2013-0188-
cachemgr_cgi_dos.diff memory leak in cachemgr.cgi known
as CVE-2013-0189, which is the underfixed CVE-2012-5643
problem. [bnc#796999] [bnc#794954]
- run logrotate as squid:nogroup [bnc#677335]


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 11.4:

zypper in -t patch 2013-132

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 11.4 (i586 x86_64):

squid-2.7.STABLE6-10.17.1
squid-debuginfo-2.7.STABLE6-10.17.1
squid-debugsource-2.7.STABLE6-10.17.1


References:

http://support.novell.com/security/cve/CVE-2012-5643.html
http://support.novell.com/security/cve/CVE-2013-0188.html
http://support.novell.com/security/cve/CVE-2013-0189.html
http://support.novell.com/security/cve/CVE-2013-4115.html
https://bugzilla.novell.com/677335
https://bugzilla.novell.com/796999
https://bugzilla.novell.com/829084


< Previous Next >
This Thread
  • No further messages