Mailinglist Archive: opensuse-updates (74 mails)

< Previous Next >
openSUSE-SU-2013:1432-1: moderate: libzypp: security fixes in RPM GPG key import parsing
openSUSE Security Update: libzypp: security fixes in RPM GPG key import
parsing
______________________________________________________________________________

Announcement ID: openSUSE-SU-2013:1432-1
Rating: moderate
References: #828672
Cross-References: CVE-2013-3704
Affected Products:
openSUSE 12.3
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:


libzypp was adjusted to enhance the RPM GPG key
import/handling to avoid a problem with multiple key blobs.

Attackers able to supplying a repository could let the
packagemanager show another keys fingerprint while a second
one was actually used to sign the repository
(CVE-2013-3704).


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 12.3:

zypper in -t patch openSUSE-2013-692

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 12.3 (i586 x86_64):

libzypp-12.15.0-1.17.1
libzypp-debuginfo-12.15.0-1.17.1
libzypp-debugsource-12.15.0-1.17.1
libzypp-devel-12.15.0-1.17.1


References:

http://support.novell.com/security/cve/CVE-2013-3704.html
https://bugzilla.novell.com/828672


< Previous Next >
This Thread
  • No further messages