Mailinglist Archive: opensuse-updates (58 mails)

< Previous Next >
openSUSE-SU-2013:1291-1: moderate: kdebase4-workspace: security fixes for denial of service problems
openSUSE Security Update: kdebase4-workspace: security fixes for denial of
service problems
______________________________________________________________________________

Announcement ID: openSUSE-SU-2013:1291-1
Rating: moderate
References: #817932 #829857
Cross-References: CVE-2013-4132 CVE-2013-4133
Affected Products:
openSUSE 12.2
______________________________________________________________________________

An update that fixes two vulnerabilities is now available.

Description:


kdebase4-workspace received fixes for:

- KDM: a potential crash in crypt() was fixed (bnc#829857,
CVE-2013-4132)

- Fixes plasma systemtray memory leak with legacy icons
(kde#314919, bnc#817932, bnc#829857, CVE-2013-4133)


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 12.2:

zypper in -t patch openSUSE-2013-625

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 12.2 (i586 x86_64):

kde4-kgreeter-plugins-4.8.5-2.18.1
kde4-kgreeter-plugins-debuginfo-4.8.5-2.18.1
kdebase4-workspace-4.8.5-2.18.1
kdebase4-workspace-branding-upstream-4.8.5-2.18.1
kdebase4-workspace-debuginfo-4.8.5-2.18.1
kdebase4-workspace-debugsource-4.8.5-2.18.1
kdebase4-workspace-devel-4.8.5-2.18.1
kdebase4-workspace-devel-debuginfo-4.8.5-2.18.1
kdebase4-workspace-ksysguardd-4.8.5-2.18.1
kdebase4-workspace-ksysguardd-debuginfo-4.8.5-2.18.1
kdebase4-workspace-liboxygenstyle-4.8.5-2.18.1
kdebase4-workspace-liboxygenstyle-debuginfo-4.8.5-2.18.1
kdebase4-workspace-plasma-calendar-4.8.5-2.18.1
kdebase4-workspace-plasma-calendar-debuginfo-4.8.5-2.18.1
kdebase4-workspace-plasma-engine-akonadi-4.8.5-2.18.1
kdebase4-workspace-plasma-engine-akonadi-debuginfo-4.8.5-2.18.1
kdm-4.8.5-2.18.1
kdm-branding-upstream-4.8.5-2.18.1
kdm-debuginfo-4.8.5-2.18.1
kwin-4.8.5-2.18.1
kwin-debuginfo-4.8.5-2.18.1
python-kdebase4-4.8.5-2.18.1

- openSUSE 12.2 (x86_64):

kdebase4-workspace-liboxygenstyle-32bit-4.8.5-2.18.1
kdebase4-workspace-liboxygenstyle-debuginfo-32bit-4.8.5-2.18.1


References:

http://support.novell.com/security/cve/CVE-2013-4132.html
http://support.novell.com/security/cve/CVE-2013-4133.html
https://bugzilla.novell.com/817932
https://bugzilla.novell.com/829857


< Previous Next >
This Thread
  • No further messages