Mailinglist Archive: opensuse-updates (200 mails)

< Previous Next >
openSUSE-SU-2013:1083-1: moderate: update for darktable
openSUSE Security Update: update for darktable
______________________________________________________________________________

Announcement ID: openSUSE-SU-2013:1083-1
Rating: moderate
References: #823114
Cross-References: CVE-2013-2126
Affected Products:
openSUSE 12.3
openSUSE 12.2
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

This update of darktable fixes a problem inside the
embedded libraw version.
- Fix for CVE-2013-2126
* added backported patch from git master
0001-fixed-error-handling-for-broken-full-color-images.patch
fixes bnc#823114-


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 12.3:

zypper in -t patch openSUSE-2013-538

- openSUSE 12.2:

zypper in -t patch openSUSE-2013-538

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 12.3 (x86_64):

darktable-1.1.3-1.5.3
darktable-debuginfo-1.1.3-1.5.3
darktable-debugsource-1.1.3-1.5.3
darktable-doc-1.1.3-1.5.3

- openSUSE 12.3 (i586):

darktable-1.1.3-1.5.4
darktable-debuginfo-1.1.3-1.5.4
darktable-debugsource-1.1.3-1.5.4
darktable-doc-1.1.3-1.5.4

- openSUSE 12.2 (i586 x86_64):

darktable-1.0.5-3.9.3
darktable-debuginfo-1.0.5-3.9.3
darktable-debugsource-1.0.5-3.9.3


References:

http://support.novell.com/security/cve/CVE-2013-2126.html
https://bugzilla.novell.com/823114


< Previous Next >
This Thread
  • No further messages