Mailinglist Archive: opensuse-updates (200 mails)

< Previous Next >
openSUSE-SU-2013:1032-1: moderate: update for libXtst
openSUSE Security Update: update for libXtst
______________________________________________________________________________

Announcement ID: openSUSE-SU-2013:1032-1
Rating: moderate
References: #815451 #821663
Cross-References: CVE-2013-2063
Affected Products:
openSUSE 12.3
openSUSE 12.2
______________________________________________________________________________

An update that solves one vulnerability and has one errata
is now available.

Description:

This update of libXtst fixes an integer overflow issue.
-
U_0001-integer-overflow-in-XRecordGetContext-CVE-2013-2063.p
atch
* integer overflow in XRecordGetContext() [CVE-2013-2063]
(bnc#821663, bnc#815451)


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 12.3:

zypper in -t patch openSUSE-2013-507

- openSUSE 12.2:

zypper in -t patch openSUSE-2013-507

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 12.3 (i586 x86_64):

libXtst-debugsource-1.2.1-4.4.1
libXtst-devel-1.2.1-4.4.1
libXtst6-1.2.1-4.4.1
libXtst6-debuginfo-1.2.1-4.4.1

- openSUSE 12.3 (x86_64):

libXtst-devel-32bit-1.2.1-4.4.1
libXtst6-32bit-1.2.1-4.4.1
libXtst6-debuginfo-32bit-1.2.1-4.4.1

- openSUSE 12.2 (i586 x86_64):

libXtst-debugsource-1.2.1-2.4.1
libXtst-devel-1.2.1-2.4.1
libXtst6-1.2.1-2.4.1
libXtst6-debuginfo-1.2.1-2.4.1

- openSUSE 12.2 (x86_64):

libXtst-devel-32bit-1.2.1-2.4.1
libXtst6-32bit-1.2.1-2.4.1
libXtst6-debuginfo-32bit-1.2.1-2.4.1


References:

http://support.novell.com/security/cve/CVE-2013-2063.html
https://bugzilla.novell.com/815451
https://bugzilla.novell.com/821663


< Previous Next >
This Thread
  • No further messages