Mailinglist Archive: opensuse-updates (200 mails)

< Previous Next >
openSUSE-SU-2013:1029-1: moderate: update for libdmx
openSUSE Security Update: update for libdmx
______________________________________________________________________________

Announcement ID: openSUSE-SU-2013:1029-1
Rating: moderate
References: #815451 #821663
Cross-References: CVE-2013-1992
Affected Products:
openSUSE 12.3
openSUSE 12.2
______________________________________________________________________________

An update that solves one vulnerability and has one errata
is now available.

Description:

This update of libdmx fixes several integer overflow issues.
-
U_0001-integer-overflow-in-DMXGetScreenAttributes-CVE-2013-.
patch,
U_0002-integer-overflow-in-DMXGetWindowAttributes-CVE-2013-.
patch,
U_0003-integer-overflow-in-DMXGetInputAttributes-CVE-2013-1.
patch,
* integer overflow in DMXGetScreenAttributes(),
DMXGetWindowAttributes(), DMXGetInputAttributes()
[CVE-2013-1992] (bnc#821663, bnc#815451)


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 12.3:

zypper in -t patch openSUSE-2013-510

- openSUSE 12.2:

zypper in -t patch openSUSE-2013-510

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 12.3 (i586 x86_64):

libdmx-debugsource-1.1.2-4.4.1
libdmx-devel-1.1.2-4.4.1
libdmx1-1.1.2-4.4.1
libdmx1-debuginfo-1.1.2-4.4.1

- openSUSE 12.3 (x86_64):

libdmx-devel-32bit-1.1.2-4.4.1
libdmx1-32bit-1.1.2-4.4.1
libdmx1-debuginfo-32bit-1.1.2-4.4.1

- openSUSE 12.2 (i586 x86_64):

libdmx-debugsource-1.1.2-2.4.1
libdmx-devel-1.1.2-2.4.1
libdmx1-1.1.2-2.4.1
libdmx1-debuginfo-1.1.2-2.4.1

- openSUSE 12.2 (x86_64):

libdmx-devel-32bit-1.1.2-2.4.1
libdmx1-32bit-1.1.2-2.4.1
libdmx1-debuginfo-32bit-1.1.2-2.4.1


References:

http://support.novell.com/security/cve/CVE-2013-1992.html
https://bugzilla.novell.com/815451
https://bugzilla.novell.com/821663


< Previous Next >
This Thread
  • No further messages